summaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
authorWilliam Deegan <bill@baddogconsulting.com>2020-03-16 04:20:38 (GMT)
committerWilliam Deegan <bill@baddogconsulting.com>2020-04-09 20:47:32 (GMT)
commit7c466f714b9892d953ff2b91c7b0214180417000 (patch)
tree1c2e2a2bcdaf16994e50f0c66dd0450d6a99bad9 /setup.cfg
parentf1538fb9000a343d87676ce110076b7cc197cb0e (diff)
downloadSCons-7c466f714b9892d953ff2b91c7b0214180417000.zip
SCons-7c466f714b9892d953ff2b91c7b0214180417000.tar.gz
SCons-7c466f714b9892d953ff2b91c7b0214180417000.tar.bz2
Initial checking of modernized setup.py. TODO: entry_points for every other script (scons.py is done)
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg64
1 files changed, 64 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..d44c1f5
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,64 @@
+[metadata]
+name = SCons
+version=3.9.9a99
+license = MIT
+author = William Deegan
+author_email =bill@baddogconsulting.com
+long_description = file: README.rst
+description = Open Source next-generation build tool.
+group = Development/Tools
+license_file = src/LICENSE.txt
+
+
+url = http://www.scons.org/
+project-urls =
+ Documentation = https://scons.org/documentation.html
+ Twitter = https://twitter.com/SConsProject
+ GitHub = https://github.com/SCons/scons
+ Bug-Tracker = https://github.com/SCons/scons/issues
+
+
+classifiers =
+ Development Status :: 5 - Production/Stable
+ Topic :: Utilities
+ Programming Language :: Python
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3 :: Only
+ Programming Language :: Python :: 3.5
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: 3.8
+ Environment :: Console
+ Intended Audience :: Developers
+ License :: OSI Approved :: MIT License
+ Operating System :: POSIX :: Linux
+ Operating System :: Unix
+ Operating System :: MacOS
+ Operating System :: Microsoft :: Windows
+
+
+[options]
+zip_safe = False
+python_requires = >=3.5
+install_requires = setuptools
+setup_requires = setuptools
+include_package_data = True
+package_dir=
+ =src/engine
+packages = find:
+
+[options.packages.find]
+ where=src/engine
+
+[options.entry_points]
+console_scripts =
+ scons = SCons.Script.Main:main
+
+
+[options.package_data]
+* = *.txt, *.rst
+SCons.Tool.docbook = *.*
+
+
+[bdist_wheel]
+universal=0