summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAdam Gross <grossag@vmware.com>2020-11-06 17:46:12 (GMT)
committerAdam Gross <grossag@vmware.com>2020-11-06 17:46:12 (GMT)
commitcc7b28e50655960e7aab2dd8581f427a0920bf38 (patch)
tree3c9e36a05f4069bf2e8699e351043254c3edd1da /setup.py
parent450b28367cdcbf10f855e43e0571915ebf9f09ca (diff)
parentebe6e9b1b2fedbe3dd44c07aa2b6739d4079879e (diff)
downloadSCons-cc7b28e50655960e7aab2dd8581f427a0920bf38.zip
SCons-cc7b28e50655960e7aab2dd8581f427a0920bf38.tar.gz
SCons-cc7b28e50655960e7aab2dd8581f427a0920bf38.tar.bz2
Merge branch 'master' into topic/grossag/newhashes
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8ea0246..6d52278 100644
--- a/setup.py
+++ b/setup.py
@@ -7,11 +7,13 @@ from setuptools.command.build_py import build_py as build_py_orig
import codecs
import os.path
+
def read(rel_path):
here = os.path.abspath(os.path.dirname(__file__))
with codecs.open(os.path.join(here, rel_path), 'r') as fp:
return fp.read()
+
def get_version(rel_path):
for line in read(rel_path).splitlines():
if line.startswith('__version__'):
@@ -21,7 +23,6 @@ def get_version(rel_path):
raise RuntimeError("Unable to find version string.")
-
exclude = ['*Tests']