summaryrefslogtreecommitdiffstats
path: root/src/script/setup.py
diff options
context:
space:
mode:
authorSteven Knight <knight@baldmt.com>2001-11-16 22:06:52 (GMT)
committerSteven Knight <knight@baldmt.com>2001-11-16 22:06:52 (GMT)
commit76166c77f852377b6139a9414cc355fe2661a0e7 (patch)
treefe77db2a491d0f8f0aa6c743c1e1f5b21a1914ed /src/script/setup.py
parent9508d219188fcd2ad8eb2d24606d1b9c611e9ed2 (diff)
downloadSCons-76166c77f852377b6139a9414cc355fe2661a0e7.zip
SCons-76166c77f852377b6139a9414cc355fe2661a0e7.tar.gz
SCons-76166c77f852377b6139a9414cc355fe2661a0e7.tar.bz2
Add the scons package.
Diffstat (limited to 'src/script/setup.py')
-rw-r--r--src/script/setup.py11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/script/setup.py b/src/script/setup.py
index a3eace7..2835cdf 100644
--- a/src/script/setup.py
+++ b/src/script/setup.py
@@ -35,10 +35,15 @@ if head:
from distutils.core import setup
-setup(name = "scons",
+setup(name = "scons-script",
version = "__VERSION__",
- description = "scons",
+ description = "an Open Source software construction tool script",
+ long_description = """SCons is an Open Source software construction tool--that is, a build tool; an
+improved substitute for the classic Make utility; a better way to build
+software.""",
author = "Steven Knight",
author_email = "knight@baldmt.com",
- url = "http://www.baldmt.com/scons",
+ url = "http://www.scons.org/",
+ licence = "MIT, freely distributable",
+ keywords = "scons, cons, make, build tool, make tool",
scripts = ["scons"])