summaryrefslogtreecommitdiffstats
path: root/src/setup.py
diff options
context:
space:
mode:
authorSteven Knight <knight@baldmt.com>2008-08-26 14:09:06 (GMT)
committerSteven Knight <knight@baldmt.com>2008-08-26 14:09:06 (GMT)
commit0535d0884dba8278368208c7ac2028ffff39d01a (patch)
tree74b4b28ebb9b368fae420b0a7bd4d754b9e76d15 /src/setup.py
parentf6bd57cdfa43fb809688a45e8b5bb2f76d82a23f (diff)
downloadSCons-0535d0884dba8278368208c7ac2028ffff39d01a.zip
SCons-0535d0884dba8278368208c7ac2028ffff39d01a.tar.gz
SCons-0535d0884dba8278368208c7ac2028ffff39d01a.tar.bz2
Issue 2112: create a separate single-line description and make the
current description the long_description to satisfy RPM packaging. (khomenko)
Diffstat (limited to 'src/setup.py')
-rw-r--r--src/setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/setup.py b/src/setup.py
index b49a7af..e1d4fab 100644
--- a/src/setup.py
+++ b/src/setup.py
@@ -361,7 +361,9 @@ class install_data(_install_data):
else:
self.data_files = []
-description = """Open Source next-generation build tool.
+description = "Open Source next-generation build tool."
+
+long_description = """Open Source next-generation build tool.
Improved, cross-platform substitute for the classic Make
utility. In short, SCons is an easier, more reliable
and faster way to build software."""
@@ -387,6 +389,7 @@ arguments = {
'name' : "scons",
'version' : Version,
'description' : description,
+ 'long_description' : long_description,
'author' : 'Steven Knight',
'author_email' : 'knight@baldmt.com',
'url' : "http://www.scons.org/",