summaryrefslogtreecommitdiffstats
path: root/tkblt/configure.ac
diff options
context:
space:
mode:
authorWilliam Joye <wjoye@cfa.harvard.edu>2019-12-19 21:17:15 (GMT)
committerWilliam Joye <wjoye@cfa.harvard.edu>2019-12-19 21:17:15 (GMT)
commit2cc7028a79456ef46c80abcd4c46b2376b7e0b33 (patch)
treee83079ba874de26c1547a18ba1ee7d0fba500b4e /tkblt/configure.ac
parentae36e7fbad8a7bbfb718e0e89893dbda8bae68be (diff)
downloadblt-2cc7028a79456ef46c80abcd4c46b2376b7e0b33.zip
blt-2cc7028a79456ef46c80abcd4c46b2376b7e0b33.tar.gz
blt-2cc7028a79456ef46c80abcd4c46b2376b7e0b33.tar.bz2
fix CXX for mingw
Diffstat (limited to 'tkblt/configure.ac')
-rw-r--r--tkblt/configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/tkblt/configure.ac b/tkblt/configure.ac
index 5aeae27..4d8f5e8 100644
--- a/tkblt/configure.ac
+++ b/tkblt/configure.ac
@@ -59,9 +59,12 @@ TEA_PREFIX
# necessary to compile executables.
#-----------------------------------------------------------------------
-AC_PROG_CXX
TEA_SETUP_COMPILER
+if test "${TEA_PLATFORM}" != "windows" ; then
+ AC_PROG_CXX
+fi
+
#-----------------------------------------------------------------------
# __CHANGE__
# Specify the C source files to compile in TEA_ADD_SOURCES,
@@ -198,6 +201,11 @@ TEA_ENABLE_SHARED
TEA_CONFIG_CFLAGS
+if test "${TEA_PLATFORM}" = "windows" ; then
+ CXX="$CC"
+ CXXFLAGS="$CFLAGS"
+fi
+
#--------------------------------------------------------------------
# Set the default compiler switches based on the --enable-symbols option.
#--------------------------------------------------------------------