summaryrefslogtreecommitdiffstats
path: root/win/configure.ac
diff options
context:
space:
mode:
authorWilliam Joye <wjoye@cfa.harvard.edu>2017-01-13 20:20:17 (GMT)
committerWilliam Joye <wjoye@cfa.harvard.edu>2017-01-13 20:20:17 (GMT)
commitf9800195f3ed5aacd92e659bf470379345711b8d (patch)
tree7294e31feb4f7212409225a4bc16c1d0bdb3b708 /win/configure.ac
parent22e70af222567275ea290368cb6c7ecdc20d66af (diff)
downloadblt-f9800195f3ed5aacd92e659bf470379345711b8d.zip
blt-f9800195f3ed5aacd92e659bf470379345711b8d.tar.gz
blt-f9800195f3ed5aacd92e659bf470379345711b8d.tar.bz2
update TEA 3.10
Diffstat (limited to 'win/configure.ac')
-rwxr-xr-xwin/configure.ac51
1 files changed, 51 insertions, 0 deletions
diff --git a/win/configure.ac b/win/configure.ac
new file mode 100755
index 0000000..b50272a
--- /dev/null
+++ b/win/configure.ac
@@ -0,0 +1,51 @@
+#!/bin/bash -norc
+dnl This file is an input file used by the GNU "autoconf" program to
+dnl generate the file "configure", which is run during Tcl installation
+dnl to configure the system for the local environment.
+
+#-----------------------------------------------------------------------
+# Sample configure.in for Tcl Extensions. The only places you should
+# need to modify this file are marked by the string __CHANGE__
+#-----------------------------------------------------------------------
+
+#-----------------------------------------------------------------------
+# __CHANGE__
+# Set your package name and version numbers here.
+#
+# This initializes the environment with PACKAGE_NAME and PACKAGE_VERSION
+# set as provided. These will also be added as -D defs in your Makefile
+# so you can encode the package version directly into the source files.
+# This will also define a special symbol for Windows (BUILD_<PACKAGE_NAME>
+# so that we create the export library with the dll.
+#-----------------------------------------------------------------------
+
+AC_INIT([saods9], [7.6])
+
+#--------------------------------------------------------------------
+# Call TEA_INIT as the first TEA_ macro to set up initial vars.
+# This will define a ${TEA_PLATFORM} variable == "unix" or "windows"
+# as well as PKG_LIB_FILE and PKG_STUB_LIB_FILE.
+#--------------------------------------------------------------------
+
+TEA_INIT([3.10])
+
+AC_CONFIG_AUX_DIR(../tclconfig)
+
+#--------------------------------------------------------------------
+
+AC_ARG_WITH([arch],AC_HELP_STRING([--with-arch],[build name]),[],[with_arch=unknown])
+
+OS="win"
+AC_SUBST(OS)
+
+ARCH=$with_arch
+AC_SUBST(ARCH)
+
+prefix=$ac_pwd
+exec_prefix=$ac_pwd
+
+CORES=`grep -c ^processor /proc/cpuinfo`
+AC_SUBST(CORES)
+
+AC_OUTPUT([Makefile])
+