summaryrefslogtreecommitdiffstats
path: root/libxslt/tests/xinclude/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libxslt/tests/xinclude/Makefile.am')
-rw-r--r--libxslt/tests/xinclude/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/libxslt/tests/xinclude/Makefile.am b/libxslt/tests/xinclude/Makefile.am
new file mode 100644
index 0000000..3562454
--- /dev/null
+++ b/libxslt/tests/xinclude/Makefile.am
@@ -0,0 +1,33 @@
+## Process this file with automake to produce Makefile.in
+
+$(top_builddir)/xsltproc/xsltproc:
+ @(cd ../../xsltproc ; $(MAKE) xsltproc)
+
+EXTRA_DIST = \
+ e.xml \
+ e.xsl \
+ x1.xml \
+ x2.xml \
+ normal.out \
+ xinclude.out
+
+CLEANFILES = .memdump
+
+valgrind:
+ @echo '## Running the regression tests under Valgrind'
+ $(MAKE) CHECKER='libtool --mode=execute valgrind -q --leak-check=full' tests
+
+test tests: $(top_builddir)/xsltproc/xsltproc
+ @echo '## Running XInclude test'
+ @(echo > .memdump)
+ @($(CHECKER) $(top_builddir)/xsltproc/xsltproc $(srcdir)/e.xsl $(srcdir)/e.xml > res ; \
+ diff $(srcdir)/normal.out res; \
+ grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0" || true;\
+ rm -f res)
+ @($(CHECKER) $(top_builddir)/xsltproc/xsltproc --xinclude $(srcdir)/e.xsl $(srcdir)/e.xml > res ; \
+ diff $(srcdir)/xinclude.out res; \
+ grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0" || true;\
+ rm -f res)
+
+
+