summaryrefslogtreecommitdiffstats
path: root/Lib/idlelib/setup.py
diff options
context:
space:
mode:
authorKurt B. Kaiser <kbk@shore.net>2001-07-16 04:00:10 (GMT)
committerKurt B. Kaiser <kbk@shore.net>2001-07-16 04:00:10 (GMT)
commit21ebb211df5ecee247e732b9220ab935854d10e2 (patch)
treedf74635258dc0fd396204474af8ffa7057337046 /Lib/idlelib/setup.py
parent51d76f1f7532d9f55e31dbf3fd4dc26be42a839a (diff)
downloadcpython-21ebb211df5ecee247e732b9220ab935854d10e2.zip
cpython-21ebb211df5ecee247e732b9220ab935854d10e2.tar.gz
cpython-21ebb211df5ecee247e732b9220ab935854d10e2.tar.bz2
Add a script "idles" which opens a Python Shell window.
The default behaviour of idlefork idle is to open an editor window instead of a shell. Complex expressions may be run in a fresh environment by selecting "run". There are times, however, when a shell is desired. Though one can be started by "idle -t 'foo'", this script is more convenient. In addition, a shell and an editor window can be started in parallel by "idles -e foo.py".
Diffstat (limited to 'Lib/idlelib/setup.py')
-rw-r--r--Lib/idlelib/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/Lib/idlelib/setup.py b/Lib/idlelib/setup.py
index ba27bed..ecdf92e 100644
--- a/Lib/idlelib/setup.py
+++ b/Lib/idlelib/setup.py
@@ -77,5 +77,5 @@ as well as a Python shell window and a debugger.""",
'install_lib':idle_install_lib},
package_dir = {idlelib:'.'},
packages = [idlelib],
- scripts = ['idle']
+ scripts = ['idle', 'idles']
)