summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2013-11-22 07:01:59 (GMT)
committerNed Deily <nad@acm.org>2013-11-22 07:01:59 (GMT)
commit322f5ba0d8d5e8a9cd2a134fa215884b4cbc373d (patch)
treee3d578e420a6d05bb5b8f1fc6a15292cc0c4f0f8 /configure.ac
parentb8f944f0b76ebfeecb181498868f10b273981668 (diff)
downloadcpython-322f5ba0d8d5e8a9cd2a134fa215884b4cbc373d.zip
cpython-322f5ba0d8d5e8a9cd2a134fa215884b4cbc373d.tar.gz
cpython-322f5ba0d8d5e8a9cd2a134fa215884b4cbc373d.tar.bz2
Issue #19553: PEP 453 - "make install" and "make altinstall" now install or
upgrade pip by default, using the bundled pip provided by the new ensurepip module. A new configure option, --with-ensurepip[=upgrade|install|no], is available to override the default ensurepip "--upgrade" option. The option can also be set with "make [alt]install ENSUREPIP=[upgrade|install\no]".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 02f481e..14b3aef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4767,6 +4767,21 @@ if test "$have_gcc_asm_for_x87" = yes; then
esac
fi
+# ensurepip option
+AC_MSG_CHECKING(for ensurepip)
+AC_ARG_WITH(ensurepip,
+ [AS_HELP_STRING([--with(out)-ensurepip=@<:@=upgrade@:>@],
+ ["install" or "upgrade" using bundled pip])],
+ [],
+ [with_ensurepip=upgrade])
+AS_CASE($with_ensurepip,
+ [yes|upgrade],[ENSUREPIP=upgrade],
+ [install],[ENSUREPIP=install],
+ [no],[ENSUREPIP=no],
+ [AC_MSG_ERROR([--with-ensurepip=upgrade|install|no])])
+AC_MSG_RESULT($ENSUREPIP)
+AC_SUBST(ENSUREPIP)
+
# generate output files
AC_CONFIG_FILES(Makefile.pre Modules/Setup.config Misc/python.pc Misc/python-config.sh)
AC_CONFIG_FILES([Modules/ld_so_aix], [chmod +x Modules/ld_so_aix])