summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlex Wang <aw1621107@gmail.com>2017-03-28 12:50:51 (GMT)
committerINADA Naoki <methane@users.noreply.github.com>2017-03-28 12:50:51 (GMT)
commit8cea5929f52801b0ce5928b46ef836e99a24321a (patch)
tree12dd5e34dd3dc16062fadbd6a7a52c8c8910ef44 /configure.ac
parentad2f9e2c8a0b44b3e6aec9d28ba59e13239236f7 (diff)
downloadcpython-8cea5929f52801b0ce5928b46ef836e99a24321a.zip
cpython-8cea5929f52801b0ce5928b46ef836e99a24321a.tar.gz
cpython-8cea5929f52801b0ce5928b46ef836e99a24321a.tar.bz2
bpo-29643: Fix check for --enable-optimizations (GH-129)
The presence of the ``--enable-optimizations`` flag is indicated by the value of ``$enableval``, but the configure script was checking ``$withval``, resulting in the ``--enable-optimizations`` flag being effectively ignored.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8ab1c03..f9bd92c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1274,7 +1274,7 @@ Py_OPT='false'
AC_MSG_CHECKING(for --enable-optimizations)
AC_ARG_ENABLE(optimizations, AS_HELP_STRING([--enable-optimizations], [Enable expensive optimizations (PGO, etc). Disabled by default.]),
[
-if test "$withval" != no
+if test "$enableval" != no
then
Py_OPT='true'
AC_MSG_RESULT(yes);