summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKyle Evans <kevans91@users.noreply.github.com>2020-10-11 20:18:53 (GMT)
committerGitHub <noreply@github.com>2020-10-11 20:18:53 (GMT)
commit1800c600801709958af66bebfa683a4e7570810f (patch)
tree6ac63c960220b9e666db1e8d2f36dd3f39068c92 /configure.ac
parentc230fde8475e4e5581e74a4235654d17ccf4cff8 (diff)
downloadcpython-1800c600801709958af66bebfa683a4e7570810f.zip
cpython-1800c600801709958af66bebfa683a4e7570810f.tar.gz
cpython-1800c600801709958af66bebfa683a4e7570810f.tar.bz2
bpo-40423: Optimization: use close_range(2) if available (GH-22651)
close_range(2) should be preferred at all times if it's available, otherwise we'll use closefrom(2) if available with a fallback to fdwalk(3) or plain old loop over fd range in order of most efficient to least. [note that this version does check for ENOSYS, but currently ignores all other errors] Automerge-Triggered-By: @pablogsal
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f0bc8c6..3ec274c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3664,8 +3664,8 @@ fi
# checks for library functions
AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
- clock confstr copy_file_range ctermid dup3 execv explicit_bzero explicit_memset \
- faccessat fchmod fchmodat fchown fchownat \
+ clock confstr close_range copy_file_range ctermid dup3 execv explicit_bzero \
+ explicit_memset faccessat fchmod fchmodat fchown fchownat \
fdwalk fexecve fdopendir fork fpathconf fstatat ftime ftruncate futimesat \
futimens futimes gai_strerror getentropy \
getgrgid_r getgrnam_r \