summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEitan Adler <grimreaper@users.noreply.github.com>2018-05-16 05:58:09 (GMT)
committerBenjamin Peterson <benjamin@python.org>2018-05-16 05:58:09 (GMT)
commit3055c947f98a078bd10d6a8cc352048a1b771d60 (patch)
tree4ac3246dc2999080150e4ddb0aedc7b169cf8e45 /configure.ac
parent2a7bacbd913cf2bf568b3c0f85a758946d3cf4e9 (diff)
downloadcpython-3055c947f98a078bd10d6a8cc352048a1b771d60.zip
cpython-3055c947f98a078bd10d6a8cc352048a1b771d60.tar.gz
cpython-3055c947f98a078bd10d6a8cc352048a1b771d60.tar.bz2
closes bpo-33512: use standard for detecting long double (GH-6847)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 883c905..679fac3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2198,16 +2198,8 @@ AC_CHECK_SIZEOF(size_t, 4)
AC_CHECK_SIZEOF(pid_t, 4)
AC_CHECK_SIZEOF(uintptr_t)
-AC_MSG_CHECKING(for long double support)
-have_long_double=no
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[long double x; x = (long double)0;]])],[
- AC_DEFINE(HAVE_LONG_DOUBLE, 1, [Define this if you have the type long double.])
- have_long_double=yes
-],[])
-AC_MSG_RESULT($have_long_double)
-if test "$have_long_double" = yes ; then
+AC_TYPE_LONG_DOUBLE
AC_CHECK_SIZEOF(long double, 16)
-fi
AC_CHECK_SIZEOF(_Bool, 1)