summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier de Gaye <xdegaye@users.sourceforge.net>2016-07-07 16:00:22 (GMT)
committerXavier de Gaye <xdegaye@users.sourceforge.net>2016-07-07 16:00:22 (GMT)
commit4afd143d3e615ce2d65bcededafb2e2bcda0768f (patch)
treecd372a0745047d042b2f7ccfead20703b9e9af3f /configure.ac
parent2954f8399914c77e048f9e3358abfadb7a3f76e9 (diff)
downloadcpython-4afd143d3e615ce2d65bcededafb2e2bcda0768f.zip
cpython-4afd143d3e615ce2d65bcededafb2e2bcda0768f.tar.gz
cpython-4afd143d3e615ce2d65bcededafb2e2bcda0768f.tar.bz2
Issue #27434: Version of interpreter running a cross-build and source version must be the same.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 60e8089..9b65ec1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,7 +62,7 @@ if test "$cross_compiling" = yes; then
if test -z "$PYTHON_FOR_BUILD"; then
for interp in python$PACKAGE_VERSION python3 python; do
which $interp >/dev/null 2>&1 || continue
- if $interp -c 'import sys;sys.exit(not sys.version_info@<:@:2@:>@ >= (3,3))'; then
+ if $interp -c "import sys;sys.exit(not '.'.join(str(n) for n in sys.version_info@<:@:2@:>@) == '$PACKAGE_VERSION')"; then
break
fi
interp=