summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2022-01-05 10:17:39 (GMT)
committerGitHub <noreply@github.com>2022-01-05 10:17:39 (GMT)
commit7e951f356ec76a5a5fdb851d71df5d120014bf3f (patch)
treef1abb5475cdc9256e2baa8449173329e5b3c3a30 /configure.ac
parent289a32baf74cad88c374a5e6b7cbf87b3f5af58c (diff)
downloadcpython-7e951f356ec76a5a5fdb851d71df5d120014bf3f.zip
cpython-7e951f356ec76a5a5fdb851d71df5d120014bf3f.tar.gz
cpython-7e951f356ec76a5a5fdb851d71df5d120014bf3f.tar.bz2
bpo-46263: Don't use MULTIARCH on FreeBSD (GH-30410)
(cherry picked from commit cae55542d23e606dde9819d5dadd7430085fcc77) Co-authored-by: Christian Heimes <christian@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0c06914..9151059 100644
--- a/configure.ac
+++ b/configure.ac
@@ -872,10 +872,14 @@ else
fi
rm -f conftest.c conftest.out
-if test x$PLATFORM_TRIPLET != xdarwin; then
- MULTIARCH=$($CC --print-multiarch 2>/dev/null)
-fi
-AC_SUBST(MULTIARCH)
+AC_MSG_CHECKING([for multiarch])
+AS_CASE([$ac_sys_system],
+ [Darwin*], [MULTIARCH=""],
+ [FreeBSD*], [MULTIARCH=""],
+ [MULTIARCH=$($CC --print-multiarch 2>/dev/null)]
+)
+AC_SUBST([MULTIARCH])
+AC_MSG_RESULT([$MULTIARCH])
if test x$PLATFORM_TRIPLET != x && test x$MULTIARCH != x; then
if test x$PLATFORM_TRIPLET != x$MULTIARCH; then
@@ -885,6 +889,7 @@ elif test x$PLATFORM_TRIPLET != x && test x$MULTIARCH = x; then
MULTIARCH=$PLATFORM_TRIPLET
fi
AC_SUBST(PLATFORM_TRIPLET)
+
if test x$MULTIARCH != x; then
MULTIARCH_CPPFLAGS="-DMULTIARCH=\\\"$MULTIARCH\\\""
fi