summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@redhat.com>2019-04-12 19:27:37 (GMT)
committerGitHub <noreply@github.com>2019-04-12 19:27:37 (GMT)
commit23a683adf803eef405d248cc9c2a7eb08a7300e2 (patch)
tree6e2c3cfbe541c098b51418c092bc8e61a20937ab /configure.ac
parent606c66a17faf34a4e74d4829e8fe5ad0d2879434 (diff)
downloadcpython-23a683adf803eef405d248cc9c2a7eb08a7300e2.zip
cpython-23a683adf803eef405d248cc9c2a7eb08a7300e2.tar.gz
cpython-23a683adf803eef405d248cc9c2a7eb08a7300e2.tar.bz2
bpo-36618: Add -fmax-type-align=8 flag for clang (GH-12809)
Add -fmax-type-align=8 to CFLAGS when clang compiler is detected. The pymalloc memory allocator aligns memory on 8 bytes. On x86-64, clang expects alignment on 16 bytes by default and so uses MOVAPS instruction which can lead to segmentation fault. Instruct clang that Python is limited to alignemnt on 8 bytes to use MOVUPS instruction instead: slower but don't trigger a SIGSEGV if the memory is not aligned on 16 bytes. Sadly, the flag must be expected to CFLAGS and not just CFLAGS_NODIST, since third party C extensions can have the same issue.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 28 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 30e8587..863b342 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1464,6 +1464,19 @@ esac
# compiler and platform. BASECFLAGS tweaks need to be made even if the
# user set OPT.
+case $CC in
+ *clang*)
+ cc_is_clang=1
+ ;;
+ *)
+ if $CC --version 2>&1 | grep -q clang
+ then
+ cc_is_clang=1
+ else
+ cc_is_clang=
+ fi
+esac
+
# tweak OPT based on compiler and platform, only if the user didn't set
# it on the command line
AC_SUBST(OPT)
@@ -1477,19 +1490,6 @@ then
WRAP="-fwrapv"
fi
- case $CC in
- *clang*)
- cc_is_clang=1
- ;;
- *)
- if $CC --version 2>&1 | grep -q clang
- then
- cc_is_clang=1
- else
- cc_is_clang=
- fi
- esac
-
if test -n "${cc_is_clang}"
then
# Clang also needs -fwrapv
@@ -1530,6 +1530,21 @@ then
esac
fi
+if test -n "${cc_is_clang}"
+then
+ # bpo-36618: Add -fmax-type-align=8 to CFLAGS when clang compiler is
+ # detected. The pymalloc memory allocator aligns memory on 8 bytes. On
+ # x86-64, clang expects alignment on 16 bytes by default and so uses MOVAPS
+ # instruction which can lead to segmentation fault. Instruct clang that
+ # Python is limited to alignemnt on 8 bytes to use MOVUPS instruction
+ # instead: slower but don't trigger a SIGSEGV if the memory is not aligned
+ # on 16 bytes.
+ #
+ # Sadly, the flag must be expected to CFLAGS and not just CFLAGS_NODIST,
+ # since third party C extensions can have the same issue.
+ CFLAGS="$CFLAGS -fmax-type-align=8"
+fi
+
AC_SUBST(BASECFLAGS)
AC_SUBST(CFLAGS_NODIST)
AC_SUBST(LDFLAGS_NODIST)