summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorErlend Egeberg Aasland <erlend.aasland@innova.no>2021-11-22 20:27:05 (GMT)
committerGitHub <noreply@github.com>2021-11-22 20:27:05 (GMT)
commit2dc7d3dda61e7ce07721f46b14c706fbc879dfd6 (patch)
tree084f525a4f3cfb66ebf1dbcde5eee0c0be33182e /configure.ac
parent1037ca5a8ea001bfa2a198e08655620234e9befd (diff)
downloadcpython-2dc7d3dda61e7ce07721f46b14c706fbc879dfd6.zip
cpython-2dc7d3dda61e7ce07721f46b14c706fbc879dfd6.tar.gz
cpython-2dc7d3dda61e7ce07721f46b14c706fbc879dfd6.tar.bz2
bpo-45847: Port xxlimited and xxlimited_35 to PY_STDLIB_MOD (GH-29707)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5757c3b..ec7d1a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6219,6 +6219,11 @@ PY_STDLIB_MOD([_testmultiphase], [test "$TEST_MODULES" = yes])
PY_STDLIB_MOD([_xxtestfuzz], [test "$TEST_MODULES" = yes])
PY_STDLIB_MOD([_ctypes_test], [test "$TEST_MODULES" = yes], [], [], [-lm])
+dnl Limited API template modules.
+dnl The limited C API is not compatible with the Py_TRACE_REFS macro.
+PY_STDLIB_MOD([xxlimited], [test "$Py_TRACE_REFS" = no])
+PY_STDLIB_MOD([xxlimited_35], [test "$Py_TRACE_REFS" = no])
+
# substitute multiline block, must come after last PY_STDLIB_MOD()
AC_SUBST([MODULE_BLOCK])