summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2022-03-22 17:42:09 (GMT)
committerGitHub <noreply@github.com>2022-03-22 17:42:09 (GMT)
commit4aea656d62860e78cd8384f2de375f0d4f1db579 (patch)
treefb22ac0872243fd981f091ebda38c646bc779305 /configure.ac
parent9b889b5bda32c2610f98114d94750ba5f3260b58 (diff)
downloadcpython-4aea656d62860e78cd8384f2de375f0d4f1db579.zip
cpython-4aea656d62860e78cd8384f2de375f0d4f1db579.tar.gz
cpython-4aea656d62860e78cd8384f2de375f0d4f1db579.tar.bz2
bpo-32033: Finalize WASI configure options (GH-32053)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4afc898..6fd95f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1898,7 +1898,9 @@ AS_CASE([$ac_sys_system/$ac_sys_emscripten_target],
],
[WASI/*], [
AC_DEFINE([_WASI_EMULATED_SIGNAL], [1], [Define to 1 if you want to emulate signals on WASI])
- LIBS="$LIBS -lwasi-emulated-signal"
+ AC_DEFINE([_WASI_EMULATED_GETPID], [1], [Define to 1 if you want to emulate getpid() on WASI])
+ AC_DEFINE([_WASI_EMULATED_PROCESS_CLOCKS], [1], [Define to 1 if you want to emulate process clocks on WASI])
+ LIBS="$LIBS -lwasi-emulated-signal -lwasi-emulated-getpid -lwasi-emulated-process-clocks"
echo "#define _WASI_EMULATED_SIGNAL 1" >> confdefs.h
]
)
@@ -6078,6 +6080,7 @@ AC_ARG_WITH(ensurepip,
[
AS_CASE([$ac_sys_system],
[Emscripten], [with_ensurepip=no],
+ [WASI], [with_ensurepip=no],
[with_ensurepip=upgrade]
)
])
@@ -6468,6 +6471,25 @@ AS_CASE([$ac_sys_system/$ac_sys_emscripten_target],
[syslog],
)
],
+ [WASI/*], [
+ PY_STDLIB_MOD_SET_NA(
+ [_ctypes],
+ [_ctypes_test],
+ [_curses],
+ [_curses_panel],
+ [_dbm],
+ [_gdbm],
+ [_scproxy],
+ [_tkinter],
+ [_xxsubinterpreters],
+ [grp],
+ [nis],
+ [ossaudiodev],
+ [pwd],
+ [spwd],
+ [syslog],
+ )
+ ],
[PY_STDLIB_MOD_SET_NA([_scproxy])]
)