summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-22 09:40:44 (GMT)
committerXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-22 09:40:44 (GMT)
commit507cbb0c0cc4d56065831a043aefe1571dce0c6f (patch)
treeee43ca40263668cb3e431b2bde80fb6e118d8690 /configure.ac
parent62497d52d940c9e203c1bf5e5d41bba52577ec6a (diff)
parentbdf0d0f0392b2438a1424fb869937d769e5a4552 (diff)
downloadcpython-507cbb0c0cc4d56065831a043aefe1571dce0c6f.zip
cpython-507cbb0c0cc4d56065831a043aefe1571dce0c6f.tar.gz
cpython-507cbb0c0cc4d56065831a043aefe1571dce0c6f.tar.bz2
Issue #28762: Merge 3.6.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1a08af3..aa98027 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3386,7 +3386,7 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
futimens futimes gai_strerror getentropy \
getgrouplist getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getresuid getresgid getpwent getspnam getspent getsid getwd \
- initgroups kill killpg lchmod lchown lockf linkat lstat lutimes mmap \
+ initgroups kill killpg lchmod lchown linkat lstat lutimes mmap \
memrchr mbrtowc mkdirat mkfifo \
mkfifoat mknod mknodat mktime mremap nice openat pathconf pause pipe2 plock poll \
posix_fallocate posix_fadvise pread \
@@ -3763,6 +3763,15 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
[AC_MSG_RESULT(no)
])
+# Issue #28762: lockf() is available on Android API level 24, but the F_LOCK
+# macro is not defined in android-ndk-r13.
+AC_MSG_CHECKING(for lockf)
+AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h> ]],[[lockf(0, F_LOCK, 0);]])],
+ [AC_DEFINE(HAVE_LOCKF, 1, Define to 1 if you have the 'lockf' function and the F_LOCK macro.)
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)
+])
+
# On OSF/1 V5.1, getaddrinfo is available, but a define
# for [no]getaddrinfo in netdb.h.
AC_MSG_CHECKING(for getaddrinfo)