summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorErlend E. Aasland <erlend.aasland@protonmail.com>2022-11-05 09:27:47 (GMT)
committerGitHub <noreply@github.com>2022-11-05 09:27:47 (GMT)
commit573b4518867a3cb3c82aa0edd8e86b073e9ff6da (patch)
tree25d070277404edaef5040dcd0ca25cf2105d0602 /configure.ac
parenta9a8c8712665377cfa83af4b632b0db529ec1853 (diff)
downloadcpython-573b4518867a3cb3c82aa0edd8e86b073e9ff6da.zip
cpython-573b4518867a3cb3c82aa0edd8e86b073e9ff6da.tar.gz
cpython-573b4518867a3cb3c82aa0edd8e86b073e9ff6da.tar.bz2
[3.11] gh-99086: Fix implicit int compiler warning in configure check for PTHREAD_SCOPE_SYSTEM (GH-99085) (#99118)
(cherry picked from commit 12078e78f6e4a21f344e4eaff529e1ff3b97734f) Co-authored-by: Sam James <sam@cmpct.info>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 79dc1f1..2cce5fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4172,7 +4172,7 @@ if test "$posix_threads" = "yes"; then
void *foo(void *parm) {
return NULL;
}
- main() {
+ int main() {
pthread_attr_t attr;
pthread_t id;
if (pthread_attr_init(&attr)) return (-1);