summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-12-06 16:13:53 (GMT)
committerGitHub <noreply@github.com>2021-12-06 16:13:53 (GMT)
commit612e59b53f0c730ce1b881f7c08dc6d49f02c123 (patch)
tree175bec8ab0204e65dbecc6aed19e09265439b9eb /configure.ac
parent98fac8bc183c113903403793ffe411358ee40d8a (diff)
downloadcpython-612e59b53f0c730ce1b881f7c08dc6d49f02c123.zip
cpython-612e59b53f0c730ce1b881f7c08dc6d49f02c123.tar.gz
cpython-612e59b53f0c730ce1b881f7c08dc6d49f02c123.tar.bz2
bpo-45950: Fix macOS framework builds of _bootstrap_python (GH-29936)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 39890fe..c7c7125 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,16 +125,16 @@ AC_ARG_WITH(
)
AC_SUBST([FREEZE_MODULE])
+dnl build-python is used for cross compiling and macOS framework builds.
AC_ARG_WITH(
[build-python],
[AS_HELP_STRING([--with-build-python=python]PYTHON_VERSION,
- [path to build python binary for cross compiling (default: python]PYTHON_VERSION[)])],
+ [path to build python binary for cross compiling (default: _bootstrap_python or python]PYTHON_VERSION[)])],
[
AC_MSG_CHECKING([for --with-build-python])
- AS_VAR_IF([cross_compiling], [no], AC_MSG_ERROR([--with-build-python only applies to cross compiling]))
AS_VAR_IF([with_build_python], [yes], [with_build_python=python$PACKAGE_VERSION])
- AS_VAR_IF([with_build_python], [no], [AC_MSG_ERROR([invalid --with-build-python option: expected path, not "no"])])
+ AS_VAR_IF([with_build_python], [no], [AC_MSG_ERROR([invalid --with-build-python option: expected path or "yes", not "no"])])
if ! $(command -v "$with_build_python" >/dev/null 2>&1); then
AC_MSG_ERROR([invalid or missing build python binary "$with_build_python"])