summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@python.org>2021-10-05 10:02:57 (GMT)
committerGitHub <noreply@github.com>2021-10-05 10:02:57 (GMT)
commit0af08f343a7b792f527b78e2a35d9453039940c2 (patch)
tree8ed6359f38c7734bde75576f2f44e8c5b42ec9ce /configure.ac
parentbd627eb7ed08a891dd1356756feb1ce2600358e4 (diff)
downloadcpython-0af08f343a7b792f527b78e2a35d9453039940c2.zip
cpython-0af08f343a7b792f527b78e2a35d9453039940c2.tar.gz
cpython-0af08f343a7b792f527b78e2a35d9453039940c2.tar.bz2
bpo-45163: Restrict added libnetwork check to builds on Haiku. (GH-28729)
For example, without the guard the check could cause macOS installer builds to fail to install on older supported macOS releases where libnetwork is not available and is not needed on any release.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 908dd28..c7cb797 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3099,8 +3099,11 @@ AC_SUBST(TZPATH)
AC_CHECK_LIB(nsl, t_open, [LIBS="-lnsl $LIBS"]) # SVR4
AC_CHECK_LIB(socket, socket, [LIBS="-lsocket $LIBS"], [], $LIBS) # SVR4 sockets
-# Haiku system library
-AC_CHECK_LIB(network, socket, [LIBS="-lnetwork $LIBS"], [], $LIBS)
+case $ac_sys_system/$ac_sys_release in
+ Haiku*)
+ AC_CHECK_LIB(network, socket, [LIBS="-lnetwork $LIBS"], [], $LIBS)
+ ;;
+esac
AC_MSG_CHECKING(for --with-libs)
AC_ARG_WITH(libs,