summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2017-09-04 21:05:32 (GMT)
committerGitHub <noreply@github.com>2017-09-04 21:05:32 (GMT)
commit14ce158e3d7c64cfcd2e74246bcafe088b95af2c (patch)
treef2888963adf7ebb4e4ae194e3a8d18239fd28f8f /configure.ac
parent5b79d60d2cdd28989f07dd4a6bdff3a9b455ab58 (diff)
downloadcpython-14ce158e3d7c64cfcd2e74246bcafe088b95af2c.zip
cpython-14ce158e3d7c64cfcd2e74246bcafe088b95af2c.tar.gz
cpython-14ce158e3d7c64cfcd2e74246bcafe088b95af2c.tar.bz2
remove configure.ac support for SGI_ABI (#3294)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 5786525..57f4492 100644
--- a/configure.ac
+++ b/configure.ac
@@ -546,24 +546,6 @@ then
AC_DEFINE(_INCLUDE__STDC_A1_SOURCE, 1, Define to include mbstate_t for mbrtowc)
fi
-#
-# SGI compilers allow the specification of the both the ABI and the
-# ISA on the command line. Depending on the values of these switches,
-# different and often incompatible code will be generated.
-#
-# The SGI_ABI variable can be used to modify the CC and LDFLAGS and
-# thus supply support for various ABI/ISA combinations. The MACHDEP
-# variable is also adjusted.
-#
-AC_SUBST(SGI_ABI)
-if test ! -z "$SGI_ABI"
-then
- CC="cc $SGI_ABI"
- LDFLAGS="$SGI_ABI $LDFLAGS"
- MACHDEP=`echo "${MACHDEP}${SGI_ABI}" | sed 's/ *//g'`
-fi
-AC_MSG_RESULT($MACHDEP)
-
# Record the configure-time value of MACOSX_DEPLOYMENT_TARGET,
# it may influence the way we can build extensions, so distutils
# needs to check it