summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2021-10-01 07:55:28 (GMT)
committerGitHub <noreply@github.com>2021-10-01 07:55:28 (GMT)
commit1ee0f94d16f150356a4b9b0a39d44ba1d2d5b9fc (patch)
treee94381603c5b5f84731ace512dbc7fbf6bc01fc7 /configure.ac
parent3e1c5d989a884cfbeb427b6fc86012b03cb95f62 (diff)
downloadcpython-1ee0f94d16f150356a4b9b0a39d44ba1d2d5b9fc.zip
cpython-1ee0f94d16f150356a4b9b0a39d44ba1d2d5b9fc.tar.gz
cpython-1ee0f94d16f150356a4b9b0a39d44ba1d2d5b9fc.tar.bz2
bpo-41710: PyThread_acquire_lock_timed() uses sem_clockwait() (GH-28662)
On Unix, if the sem_clockwait() function is available in the C library (glibc 2.30 and newer), the threading.Lock.acquire() method now uses the monotonic clock (time.CLOCK_MONOTONIC) for the timeout, rather than using the system clock (time.CLOCK_REALTIME), to not be affected by system clock changes. configure now checks if the sem_clockwait() function is available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 48d86ef..908dd28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3744,7 +3744,7 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
posix_fallocate posix_fadvise posix_spawn posix_spawnp pread preadv preadv2 \
pthread_condattr_setclock pthread_init pthread_kill pwrite pwritev pwritev2 \
readlink readlinkat readv realpath renameat \
- sem_open sem_timedwait sem_getvalue sem_unlink sendfile setegid seteuid \
+ sem_open sem_timedwait sem_clockwait sem_getvalue sem_unlink sendfile setegid seteuid \
setgid sethostname \
setlocale setregid setreuid setresuid setresgid setsid setpgid setpgrp setpriority setuid setvbuf \
sched_get_priority_max sched_setaffinity sched_setscheduler sched_setparam \