summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-03-19 09:29:25 (GMT)
committerGitHub <noreply@github.com>2021-03-19 09:29:25 (GMT)
commit32eba61ea431c76f15a910c0a4eded7f5f8b9b34 (patch)
tree4e927023cfd797501d0dc8cf160068acfb4f61b9 /configure.ac
parentff8c77fe96c1e0e1822f3b821e9c6dcfbec22a56 (diff)
downloadcpython-32eba61ea431c76f15a910c0a4eded7f5f8b9b34.zip
cpython-32eba61ea431c76f15a910c0a4eded7f5f8b9b34.tar.gz
cpython-32eba61ea431c76f15a910c0a4eded7f5f8b9b34.tar.bz2
bpo-43466: Add --with-openssl-rpath configure option (GH-24820)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9802c65..4c3c80f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5808,6 +5808,30 @@ if test "$have_openssl" = yes; then
LIBS="$save_LIBS"
fi
+# rpath to libssl and libcrypto
+AC_MSG_CHECKING(for --with-openssl-rpath)
+AC_ARG_WITH(openssl-rpath,
+ AS_HELP_STRING([--with-openssl-rpath=@<:@DIR|auto|no@:>@],
+ [Set runtime library directory (rpath) for OpenSSL libraries,
+ no (default): don't set rpath,
+ auto: auto-detect rpath from --with-openssl and pkg-config,
+ DIR: set an explicit rpath
+ ]),
+ [],
+ [with_openssl_rpath=no]
+)
+AS_CASE($with_openssl_rpath,
+ [auto|yes],[OPENSSL_RPATH=auto],
+ [no],[OPENSSL_RPATH=],
+ [AS_IF(
+ [test -d "$with_openssl_rpath"],
+ [OPENSSL_RPATH="$with_openssl_rpath"],
+ AC_MSG_ERROR([--with-openssl-rpath "$with_openssl_rpath" is not a directory]))
+ ]
+)
+AC_MSG_RESULT($OPENSSL_RPATH)
+AC_SUBST([OPENSSL_RPATH])
+
# ssl module default cipher suite string
AH_TEMPLATE(PY_SSL_DEFAULT_CIPHERS,
[Default cipher suites list for ssl module.