summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2022-01-12 19:27:37 (GMT)
committerGitHub <noreply@github.com>2022-01-12 19:27:37 (GMT)
commite34c9367f8e0068ca4bcad9fb5c2c1024d02a77d (patch)
tree652196b8d16c2478fda8c0b232179ebb62a4b6f6 /configure.ac
parentfc05e6bfce5d5dfc23859e6f7862c1e707a12e42 (diff)
downloadcpython-e34c9367f8e0068ca4bcad9fb5c2c1024d02a77d.zip
cpython-e34c9367f8e0068ca4bcad9fb5c2c1024d02a77d.tar.gz
cpython-e34c9367f8e0068ca4bcad9fb5c2c1024d02a77d.tar.bz2
bpo-40280: Allow to compile _testcapi as builtin module (GH-30559)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 25181c0..4396828 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6309,8 +6309,8 @@ AC_ARG_ENABLE(test-modules,
if test "$enable_test_modules" = no; then
TEST_MODULES=no
else
- AS_CASE([$ac_sys_system],
- [Emscripten], [TEST_MODULES=no],
+ AS_CASE([$ac_sys_system/$ac_sys_emscripten_target],
+ [Emscripten/browser], [TEST_MODULES=no],
[TEST_MODULES=yes]
)
fi