summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Protzenko <protz@microsoft.com>2023-02-14 09:25:16 (GMT)
committerGitHub <noreply@github.com>2023-02-14 09:25:16 (GMT)
commite5da9ab2c82c6b4e4f8ffa699a9a609ea1bea255 (patch)
tree82536d304ac00d1450ea2d8923b0c5d504ebd320 /configure.ac
parent8be8101bca34b60481ec3d7ecaea4a3379fb7dbb (diff)
downloadcpython-e5da9ab2c82c6b4e4f8ffa699a9a609ea1bea255.zip
cpython-e5da9ab2c82c6b4e4f8ffa699a9a609ea1bea255.tar.gz
cpython-e5da9ab2c82c6b4e4f8ffa699a9a609ea1bea255.tar.bz2
gh-99108: Import SHA2-384/512 from HACL* (#101707)
Replace the builtin hashlib implementations of SHA2-384 and SHA2-512 originally from LibTomCrypt with formally verified, side-channel resistant code from the [HACL*](https://github.com/hacl-star/hacl-star/) project. The builtins remain a fallback only used when OpenSSL does not provide them.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1ab48e0..92a05c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7200,7 +7200,9 @@ PY_STDLIB_MOD([_sha1], [test "$with_builtin_sha1" = yes])
PY_STDLIB_MOD([_sha256],
[test "$with_builtin_sha256" = yes], [],
[-I\$(srcdir)/Modules/_hacl/include -I\$(srcdir)/Modules/_hacl/internal -D_BSD_SOURCE -D_DEFAULT_SOURCE])
-PY_STDLIB_MOD([_sha512], [test "$with_builtin_sha512" = yes])
+PY_STDLIB_MOD([_sha512],
+ [test "$with_builtin_sha512" = yes], [],
+ [-I\$(srcdir)/Modules/_hacl/include -I\$(srcdir)/Modules/_hacl/internal -D_BSD_SOURCE -D_DEFAULT_SOURCE])
PY_STDLIB_MOD([_sha3], [test "$with_builtin_sha3" = yes])
PY_STDLIB_MOD([_blake2],
[test "$with_builtin_blake2" = yes], [],