summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2013-05-13 04:08:28 (GMT)
committerBenjamin Peterson <benjamin@python.org>2013-05-13 04:08:28 (GMT)
commitf6b687fcd4d62e53443e23376dc02c177fecc0d4 (patch)
treee9de3846d9babce511548b0ed3f19bf0d2fa3b99 /configure.ac
parentfa6bdc6d8651e8240f2964ea628a188fb2d594c6 (diff)
downloadcpython-f6b687fcd4d62e53443e23376dc02c177fecc0d4.zip
cpython-f6b687fcd4d62e53443e23376dc02c177fecc0d4.tar.gz
cpython-f6b687fcd4d62e53443e23376dc02c177fecc0d4.tar.bz2
remove support GCC PyArg_ParseTuple format patch, last seen in 2006
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index a70a752..03f9072 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1328,24 +1328,6 @@ then
BASECFLAGS="$BASECFLAGS $ac_arch_flags"
fi
-# Check whether GCC supports PyArg_ParseTuple format
-if test "$GCC" = "yes"
-then
- AC_MSG_CHECKING(whether gcc supports ParseTuple __format__)
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror -Wformat"
- AC_COMPILE_IFELSE([
- AC_LANG_PROGRAM([[void f(char*,...)__attribute((format(PyArg_ParseTuple, 1, 2)));]], [[]])
- ],[
- AC_DEFINE(HAVE_ATTRIBUTE_FORMAT_PARSETUPLE, 1,
- [Define if GCC supports __attribute__((format(PyArg_ParseTuple, 2, 3)))])
- AC_MSG_RESULT(yes)
- ],[
- AC_MSG_RESULT(no)
- ])
- CFLAGS=$save_CFLAGS
-fi
-
# On some compilers, pthreads are available without further options
# (e.g. MacOS X). On some of these systems, the compiler will not
# complain if unaccepted options are passed (e.g. gcc on Mac OS X).