summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHood Chatham <roberthoodchatham@gmail.com>2022-04-03 20:58:52 (GMT)
committerGitHub <noreply@github.com>2022-04-03 20:58:52 (GMT)
commit087d0fa5b97796560c0d8ceab4f0360fd54baf4f (patch)
tree975274b43e0cc50d11f70ba0c6a8fd344d74d632 /configure.ac
parentbdc497496548e30fa208a8d98c30bf6d1833ac4c (diff)
downloadcpython-087d0fa5b97796560c0d8ceab4f0360fd54baf4f.zip
cpython-087d0fa5b97796560c0d8ceab4f0360fd54baf4f.tar.gz
cpython-087d0fa5b97796560c0d8ceab4f0360fd54baf4f.tar.bz2
bpo-47176: Interrupt handling for wasm32-emscripten builds without pthreads (GH-32209)
Co-authored-by: Christian Heimes <christian@python.org> Co-authored-by: Brett Cannon <brett@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84bc9b3..9f0a50e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4187,6 +4187,19 @@ then
fi
fi
+dnl Platform-specific C and header files.
+PLATFORM_HEADERS=
+PLATFORM_OBJS=
+
+AS_CASE([$ac_sys_system],
+ [Emscripten], [
+ AS_VAR_APPEND([PLATFORM_OBJS], [' Python/emscripten_signal.o'])
+ AS_VAR_APPEND([PLATFORM_HEADERS], [' $(srcdir)/Include/internal/pycore_emscripten_signal.h'])
+ ],
+)
+AC_SUBST([PLATFORM_HEADERS])
+AC_SUBST([PLATFORM_OBJS])
+
# -I${DLINCLDIR} is added to the compile rule for importdl.o
AC_SUBST(DLINCLDIR)
DLINCLDIR=.