summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Shannon <mark@hotpy.org>2021-12-15 15:32:32 (GMT)
committerGitHub <noreply@github.com>2021-12-15 15:32:32 (GMT)
commit342b93f9f28746abb7b221a61d5a9b26ccbb395a (patch)
treeebbe62af5b0853d8a8922c203174a88553ad798f /configure.ac
parent3a60bfef49b3324660a615a8e6d10710e5f669d9 (diff)
downloadcpython-342b93f9f28746abb7b221a61d5a9b26ccbb395a.zip
cpython-342b93f9f28746abb7b221a61d5a9b26ccbb395a.tar.gz
cpython-342b93f9f28746abb7b221a61d5a9b26ccbb395a.tar.bz2
bpo-46072: Add --with-pystats configure option to simplify gathering of VM stats (GH-30116)
* Simplify specialization stats collection macros. * Add --enable-pystats option to configure. * Update specialization summary script to handle larger number of kinds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5256a61..86404bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1387,6 +1387,21 @@ then
AC_DEFINE(Py_TRACE_REFS, 1, [Define if you want to enable tracing references for debugging purpose])
fi
+
+# Check for --enable-pystats
+AC_MSG_CHECKING([for --enable-pystats])
+AC_ARG_ENABLE([pystats],
+ [AS_HELP_STRING(
+ [--enable-pystats],
+ [enable internal statistics gathering (default is no)])],,
+ [enable_pystats=no]
+)
+AC_MSG_RESULT([$enable_pystats])
+
+AS_VAR_IF([enable_pystats], [yes], [
+ AC_DEFINE([Py_STATS], [1], [Define if you want to enable internal statistics gathering.])
+])
+
# Check for --with-assertions.
# This allows enabling assertions without Py_DEBUG.
assertions='false'
@@ -6323,7 +6338,7 @@ AC_DEFUN([PY_STDLIB_MOD], [
])
dnl Define simple stdlib extension module
-dnl Always enable unless the module is listed in py_stdlib_not_available
+dnl Always enable unless the module is listed in py_stdlib_not_available
dnl PY_STDLIB_MOD_SIMPLE([NAME], [CFLAGS], [LDFLAGS])
dnl cflags and ldflags are optional
AC_DEFUN([PY_STDLIB_MOD_SIMPLE], [