summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorkarl ding <karlding@users.noreply.github.com>2020-04-29 22:31:19 (GMT)
committerGitHub <noreply@github.com>2020-04-29 22:31:19 (GMT)
commit360371f79c48f15bbcee7aeecacf97a899913b25 (patch)
treecfccbf6ede96666eaafff463e4296c714da16d8b /configure.ac
parentfd33cdbd05d2fbe2443554a9b79155de07b0d056 (diff)
downloadcpython-360371f79c48f15bbcee7aeecacf97a899913b25.zip
cpython-360371f79c48f15bbcee7aeecacf97a899913b25.tar.gz
cpython-360371f79c48f15bbcee7aeecacf97a899913b25.tar.bz2
bpo-40291: Add support for CAN_J1939 sockets (GH-19538)
Add support for CAN_J1939 sockets that wrap SAE J1939 protocol functionality provided by Linux 5.4+ kernels.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 240ddeb..f996051 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2236,8 +2236,8 @@ AC_CHECK_HEADERS(linux/vm_sockets.h,,,[
#endif
])
-# On Linux, can.h and can/raw.h require sys/socket.h
-AC_CHECK_HEADERS(linux/can.h linux/can/raw.h linux/can/bcm.h,,,[
+# On Linux, can.h, can/bcm.h, can/j1939.h, can/raw.h require sys/socket.h
+AC_CHECK_HEADERS(linux/can.h linux/can/bcm.h linux/can/j1939.h linux/can/raw.h,,,[
#ifdef HAVE_SYS_SOCKET_H
#include <sys/socket.h>
#endif