summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorwasiher <watashiwaher@gmail.com>2020-07-27 03:28:45 (GMT)
committerGitHub <noreply@github.com>2020-07-27 03:28:45 (GMT)
commit5798f787779006a94a55ec74a86da4627de90146 (patch)
tree9505036fd4ddf510adfffb62c6ad6bb2c665bd8c /configure.ac
parentf1d40f941a6483b1d4ea10f1051ace7b426fb8e7 (diff)
downloadcpython-5798f787779006a94a55ec74a86da4627de90146.zip
cpython-5798f787779006a94a55ec74a86da4627de90146.tar.gz
cpython-5798f787779006a94a55ec74a86da4627de90146.tar.bz2
bpo-41340: Removed fallback implementation for strdup (GH-21634)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5a3e340..07c0585 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3970,7 +3970,7 @@ AC_CHECK_FUNCS(forkpty,,
# check for long file support functions
AC_CHECK_FUNCS(fseek64 fseeko fstatvfs ftell64 ftello statvfs)
-AC_REPLACE_FUNCS(dup2 strdup)
+AC_REPLACE_FUNCS(dup2)
AC_CHECK_FUNCS(getpgrp,
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h>]], [[getpgrp(0);]])],
[AC_DEFINE(GETPGRP_HAVE_ARG, 1, [Define if getpgrp() must be called as getpgrp(0).])],