summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2021-01-20 16:07:21 (GMT)
committerGitHub <noreply@github.com>2021-01-20 16:07:21 (GMT)
commit75e59a97f5d1fddb0c30ed9747b1b8cb84420a62 (patch)
treee1b32b3f0f8aaa038a4485a527157a9fac444608 /configure.ac
parentc1c3493fb7a3af8efdc50175e592d29e8cb93886 (diff)
downloadcpython-75e59a97f5d1fddb0c30ed9747b1b8cb84420a62.zip
cpython-75e59a97f5d1fddb0c30ed9747b1b8cb84420a62.tar.gz
cpython-75e59a97f5d1fddb0c30ed9747b1b8cb84420a62.tar.bz2
bpo-42856: Add --with-wheel-pkg-dir=PATH configure option (GH-24210)
Add --with-wheel-pkg-dir=PATH option to the ./configure script. If specified, the ensurepip module looks for setuptools and pip wheel packages in this directory: if both are present, these wheel packages are used instead of ensurepip bundled wheel packages. Some Linux distribution packaging policies recommend against bundling dependencies. For example, Fedora installs wheel packages in the /usr/share/python-wheels/ directory and don't install the ensurepip._bundled package. ensurepip: Remove unused runpy import.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08c462a..99077e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4838,6 +4838,22 @@ else
fi
AC_SUBST(LIBPL)
+# Check for --with-wheel-pkg-dir=PATH
+AC_SUBST(WHEEL_PKG_DIR)
+WHEEL_PKG_DIR=""
+AC_MSG_CHECKING(for --with-wheel-pkg-dir)
+AC_ARG_WITH(wheel-pkg-dir,
+ AS_HELP_STRING([--with-wheel-pkg-dir=PATH],
+ [Directory of wheel packages used by ensurepip (default: none)]),
+[
+if test -n "$withval"; then
+ AC_MSG_RESULT(yes)
+ WHEEL_PKG_DIR="$withval"
+else
+ AC_MSG_RESULT(no)
+fi],
+[AC_MSG_RESULT(no)])
+
# Check whether right shifting a negative integer extends the sign bit
# or fills with zeros (like the Cray J90, according to Tim Peters).
AC_MSG_CHECKING(whether right shift extends the sign bit)