summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorInada Naoki <songofacandy@gmail.com>2021-10-10 08:29:46 (GMT)
committerGitHub <noreply@github.com>2021-10-10 08:29:46 (GMT)
commitad970e8623523a8656e8c1ff4e1dff3423498a5a (patch)
treeddd33e1925765792c97a500b6d8bf88ca899d53c /configure.ac
parenta1c3c9e8245a88cf37b084869b3559638116daf7 (diff)
downloadcpython-ad970e8623523a8656e8c1ff4e1dff3423498a5a.zip
cpython-ad970e8623523a8656e8c1ff4e1dff3423498a5a.tar.gz
cpython-ad970e8623523a8656e8c1ff4e1dff3423498a5a.tar.bz2
bpo-29410: Change the default hash algorithm to SipHash13. (GH-28752)
Co-authored-by: Erlend Egeberg Aasland <erlend.aasland@innova.no> Co-authored-by: Christian Heimes <christian@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c7cb797..6c65b29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3036,16 +3036,19 @@ fi
# str, bytes and memoryview hash algorithm
AH_TEMPLATE(Py_HASH_ALGORITHM,
[Define hash algorithm for str, bytes and memoryview.
- SipHash24: 1, FNV: 2, externally defined: 0])
+ SipHash24: 1, FNV: 2, SipHash13: 3, externally defined: 0])
AC_MSG_CHECKING(for --with-hash-algorithm)
dnl quadrigraphs "@<:@" and "@:>@" produce "[" and "]" in the output
AC_ARG_WITH(hash_algorithm,
- AS_HELP_STRING([--with-hash-algorithm=@<:@fnv|siphash24@:>@],
- [select hash algorithm for use in Python/pyhash.c (default is SipHash24)]),
+ AS_HELP_STRING([--with-hash-algorithm=@<:@fnv|siphash13|siphash24@:>@],
+ [select hash algorithm for use in Python/pyhash.c (default is SipHash13)]),
[
AC_MSG_RESULT($withval)
case "$withval" in
+ siphash13)
+ AC_DEFINE(Py_HASH_ALGORITHM, 3)
+ ;;
siphash24)
AC_DEFINE(Py_HASH_ALGORITHM, 1)
;;