summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2020-08-29 15:00:08 (GMT)
committerGitHub <noreply@github.com>2020-08-29 15:00:08 (GMT)
commite6dcd371b2c54a94584dd124e8c592a496d46a47 (patch)
tree507d9535a82fe4bdcadc6d6dd8de2232c8298f98 /configure.ac
parent8784d3300ec4ffc58bc0e9ab3cff9a24187dbe4c (diff)
downloadcpython-e6dcd371b2c54a94584dd124e8c592a496d46a47.zip
cpython-e6dcd371b2c54a94584dd124e8c592a496d46a47.tar.gz
cpython-e6dcd371b2c54a94584dd124e8c592a496d46a47.tar.bz2
bpo-19521: Fix parallel build race condition on AIX (GH-21997)
Patch by Michael Haubenwallner.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 18 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 07c0585..3b40f39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1024,21 +1024,12 @@ LDVERSION="$VERSION"
# If CXX is set, and if it is needed to link a main function that was
# compiled with CXX, LINKCC is CXX instead. Always using CXX is undesirable:
# python might then depend on the C++ runtime
-# This is altered for AIX in order to build the export list before
-# linking.
AC_SUBST(LINKCC)
AC_MSG_CHECKING(LINKCC)
if test -z "$LINKCC"
then
LINKCC='$(PURIFY) $(MAINCC)'
case $ac_sys_system in
- AIX*)
- exp_extra="\"\""
- if test $ac_sys_release -ge 5 -o \
- $ac_sys_release -eq 4 -a `uname -r` -ge 2 ; then
- exp_extra="."
- fi
- LINKCC="\$(srcdir)/Modules/makexp_aix Modules/python.exp $exp_extra \$(LIBRARY); $LINKCC";;
QNX*)
# qcc must be used because the other compilers do not
# support -N.
@@ -1047,6 +1038,24 @@ then
fi
AC_MSG_RESULT($LINKCC)
+# EXPORTSYMS holds the list of exported symbols for AIX.
+# EXPORTSFROM holds the module name exporting symbols on AIX.
+EXPORTSYMS=
+EXPORTSFROM=
+AC_SUBST(EXPORTSYMS)
+AC_SUBST(EXPORTSFROM)
+AC_MSG_CHECKING(EXPORTSYMS)
+case $ac_sys_system in
+AIX*)
+ EXPORTSYMS="Modules/python.exp"
+ if test $ac_sys_release -ge 5 -o \
+ $ac_sys_release -eq 4 -a `uname -r` -ge 2 ; then
+ EXPORTSFROM=. # the main executable
+ fi
+ ;;
+esac
+AC_MSG_RESULT($EXPORTSYMS)
+
# GNULD is set to "yes" if the GNU linker is used. If this goes wrong
# make sure we default having it set to "no": this is used by
# distutils.unixccompiler to know if it should add --enable-new-dtags