summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Panter <vadmium+py@gmail.com>2016-07-28 01:28:27 (GMT)
committerMartin Panter <vadmium+py@gmail.com>2016-07-28 01:28:27 (GMT)
commiteac67be948e972dc12b7b4abfa83b09becf6422c (patch)
tree0a6627d7d36fcb503c5330aec167280582390520 /configure.ac
parente33797b686d764014aeaf80d7b4cb24863d238d9 (diff)
downloadcpython-eac67be948e972dc12b7b4abfa83b09becf6422c.zip
cpython-eac67be948e972dc12b7b4abfa83b09becf6422c.tar.gz
cpython-eac67be948e972dc12b7b4abfa83b09becf6422c.tar.bz2
Issue #27490: Do not build pgen when cross-compiling
The dependendency on the $(PGEN) variable must only be set when not cross-compiling. When cross-compiling, $(PGEN) will not be used, so no need to build it. Patch by Thomas Perl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bf27ab8..bf2a348 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,12 +81,15 @@ if test "$cross_compiling" = yes; then
AC_MSG_RESULT($interp)
PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/$(PLATDIR) '$interp
fi
+ PGEN_DEPENDENCY=''
elif test "$cross_compiling" = maybe; then
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
else
PYTHON_FOR_BUILD='./$(BUILDPYTHON) -E'
+ PGEN_DEPENDENCY='$(PGEN)'
fi
AC_SUBST(PYTHON_FOR_BUILD)
+AC_SUBST(PGEN_DEPENDENCY)
dnl Ensure that if prefix is specified, it does not end in a slash. If
dnl it does, we get path names containing '//' which is both ugly and