summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-10-25 08:25:27 (GMT)
committerGitHub <noreply@github.com>2021-10-25 08:25:27 (GMT)
commitfa26245a1c1aa938cce391348d6bd879da357522 (patch)
treeb193ebf766f3105a880ce8d8f7160b090b0c77b2 /configure.ac
parent51ed2c56a1852cd6b09c85ba81312dc9782772ce (diff)
downloadcpython-fa26245a1c1aa938cce391348d6bd879da357522.zip
cpython-fa26245a1c1aa938cce391348d6bd879da357522.tar.gz
cpython-fa26245a1c1aa938cce391348d6bd879da357522.tar.bz2
bpo-45548: Remove _math.c workarounds for pre-C99 libm (GH-29179)
The :mod:`math` and :mod:`cmath` implementation now require a C99 compatible ``libm`` and no longer ship with workarounds for missing acosh, asinh, expm1, and log1p functions. The changeset also removes ``_math.c`` and moves the last remaining workaround into ``_math.h``. This simplifies static builds with ``Modules/Setup`` and resolves symbol conflicts. Co-authored-by: Mark Dickinson <mdickinson@enthought.com> Co-authored-by: Brett Cannon <brett@python.org> Signed-off-by: Christian Heimes <christian@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index edda08d..4093938 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4692,8 +4692,12 @@ fi
LIBS_SAVE=$LIBS
LIBS="$LIBS $LIBM"
-AC_CHECK_FUNCS([acosh asinh atanh erf erfc expm1 finite gamma])
-AC_CHECK_FUNCS([lgamma log1p log2 tgamma])
+AC_CHECK_FUNCS(
+ [acosh asinh atanh erf erfc expm1 finite gamma lgamma log1p log2 tgamma],
+ [],
+ [AC_MSG_ERROR([Python requires C99 compatible libm])]
+)
+LIBS=$LIBS_SAVE
# For multiprocessing module, check that sem_open
# actually works. For FreeBSD versions <= 7.2,