summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2022-06-18 08:19:48 (GMT)
committerGitHub <noreply@github.com>2022-06-18 08:19:48 (GMT)
commit084023ccbeb3bf54a2e19873c6a4b0bec7b617f6 (patch)
treec1ab31a7f08487ccd1b2cc80df4467dcf16716b2 /configure.ac
parentb96d56d4340daf19e3fe8d9371dda278ef7a4656 (diff)
downloadcpython-084023ccbeb3bf54a2e19873c6a4b0bec7b617f6.zip
cpython-084023ccbeb3bf54a2e19873c6a4b0bec7b617f6.tar.gz
cpython-084023ccbeb3bf54a2e19873c6a4b0bec7b617f6.tar.bz2
gh-84461: Fix circulare dependency on BUILDPYTHON (GH-93977)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c207a81..1a17bdb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,6 +143,7 @@ AS_VAR_IF([cross_compiling], [yes],
FREEZE_MODULE_BOOTSTRAP_DEPS='$(srcdir)/Programs/_freeze_module.py'
FREEZE_MODULE='$(FREEZE_MODULE_BOOTSTRAP)'
FREEZE_MODULE_DEPS='$(FREEZE_MODULE_BOOTSTRAP_DEPS)'
+ PYTHON_FOR_BUILD_DEPS=''
],
[
dnl internal build tools also depend on Programs/_freeze_module and _bootstrap_python.
@@ -150,12 +151,14 @@ AS_VAR_IF([cross_compiling], [yes],
FREEZE_MODULE_BOOTSTRAP_DEPS="Programs/_freeze_module"
FREEZE_MODULE='$(PYTHON_FOR_FREEZE) $(srcdir)/Programs/_freeze_module.py'
FREEZE_MODULE_DEPS="_bootstrap_python \$(srcdir)/Programs/_freeze_module.py"
+ PYTHON_FOR_BUILD_DEPS='$(BUILDPYTHON)'
]
)
AC_SUBST([FREEZE_MODULE_BOOTSTRAP])
AC_SUBST([FREEZE_MODULE_BOOTSTRAP_DEPS])
AC_SUBST([FREEZE_MODULE])
AC_SUBST([FREEZE_MODULE_DEPS])
+AC_SUBST([PYTHON_FOR_BUILD_DEPS])
AC_CHECK_PROGS([PYTHON_FOR_REGEN],
[python$PACKAGE_VERSION python3.10 python3.9 python3.8 python3.7 python3.6 python3 python],