summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2015-04-16 00:11:47 (GMT)
committerNed Deily <nad@acm.org>2015-04-16 00:11:47 (GMT)
commit3b8124884c3655b4cf2629d741b18c1a38181805 (patch)
treee783186567c2f18bbe7f5ec0f94d3f0341e12b7d /configure.ac
parent20416f7994d1efbca1158e549ec8ece5ac4dbb67 (diff)
downloadcpython-3b8124884c3655b4cf2629d741b18c1a38181805.zip
cpython-3b8124884c3655b4cf2629d741b18c1a38181805.tar.gz
cpython-3b8124884c3655b4cf2629d741b18c1a38181805.tar.bz2
Issues #22980, 23969: For OS X, use PEP 3149-style file names for extension
module binaries, with a platform triple of just "darwin", resulting in file names like: _ssl.cpython-35m-darwin.so rather than just _ssl.so as previously. Instead of attempting to encode differences in CPU architecture and OS X deployment targets in the file name as is done on other platforms, these continue to be managed by the use of Apple multi-architecture ("fat") files, by the system dynamic loader, and by logic in higher-levels like sysconfig.get_platform() and pip.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 26d7b36..73a0a2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -826,6 +826,8 @@ cat >> conftest.c <<EOF
# endif
#elif defined(__gnu_hurd__)
i386-gnu
+#elif defined(__APPLE__)
+ darwin
#else
# error unknown platform triplet
#endif
@@ -4310,7 +4312,7 @@ AC_MSG_RESULT($SOABI)
AC_SUBST(EXT_SUFFIX)
case $ac_sys_system in
- Linux*|GNU*)
+ Linux*|GNU*|Darwin)
EXT_SUFFIX=.${SOABI}${SHLIB_SUFFIX};;
*)
EXT_SUFFIX=${SHLIB_SUFFIX};;