summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid CARLIER <devnexen@gmail.com>2021-09-11 08:46:22 (GMT)
committerGitHub <noreply@github.com>2021-09-11 08:46:22 (GMT)
commit5f5b7d0c654488206ac13e27d9a5dcffbd2cc0af (patch)
tree16380d83e75a66b69d6344746ed7f1811f99ca20 /configure.ac
parentb74c819fab86bedc9b962ea42cfb9b5893fd2dda (diff)
downloadcpython-5f5b7d0c654488206ac13e27d9a5dcffbd2cc0af.zip
cpython-5f5b7d0c654488206ac13e27d9a5dcffbd2cc0af.tar.gz
cpython-5f5b7d0c654488206ac13e27d9a5dcffbd2cc0af.tar.bz2
bpo-45163: Haiku build fix. (GH-28269)
linkage issues mainly for shared libs and missing system library, also little nit into the signal extension as strsignal returns a constant in this platform.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e01e0c1..bcb2054 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2736,7 +2736,7 @@ then
BLDSHARED="$LDSHARED"
fi
;;
- Linux*|GNU*|QNX*|VxWorks*)
+ Linux*|GNU*|QNX*|VxWorks*|Haiku*)
LDSHARED='$(CC) -shared'
LDCXXSHARED='$(CXX) -shared';;
FreeBSD*)
@@ -2805,6 +2805,7 @@ then
Linux-android*) ;;
Linux*|GNU*) CCSHARED="-fPIC";;
FreeBSD*|NetBSD*|OpenBSD*|DragonFly*) CCSHARED="-fPIC";;
+ Haiku*) CCSHARED="-fPIC";;
OpenUNIX*|UnixWare*)
if test "$GCC" = "yes"
then CCSHARED="-fPIC"
@@ -3098,6 +3099,9 @@ AC_SUBST(TZPATH)
AC_CHECK_LIB(nsl, t_open, [LIBS="-lnsl $LIBS"]) # SVR4
AC_CHECK_LIB(socket, socket, [LIBS="-lsocket $LIBS"], [], $LIBS) # SVR4 sockets
+# Haiku system library
+AC_CHECK_LIB(network, socket, [LIBS="-lnetwork $LIBS"], [], $LIBS)
+
AC_MSG_CHECKING(for --with-libs)
AC_ARG_WITH(libs,
AS_HELP_STRING([--with-libs='lib1 ...'], [link against additional libs (default is no)]),