summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorErlend Egeberg Aasland <erlend.aasland@innova.no>2021-11-20 14:02:52 (GMT)
committerGitHub <noreply@github.com>2021-11-20 14:02:52 (GMT)
commit6d430ef5ab62158a200b94dff31b89524a9576bb (patch)
treed29aa578c389e33e06caa1c8b7f7a064ab07cbe5 /configure.ac
parentbc2bc0dbdb52498d009f9f9771452e6aa4faff2b (diff)
downloadcpython-6d430ef5ab62158a200b94dff31b89524a9576bb.zip
cpython-6d430ef5ab62158a200b94dff31b89524a9576bb.tar.gz
cpython-6d430ef5ab62158a200b94dff31b89524a9576bb.tar.bz2
bpo-45774: Fix SQLite load extension autodetection (GH-29659)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9246597..f4adab1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3196,7 +3196,9 @@ AC_CHECK_HEADER([sqlite3.h], [
], [])
], [have_supported_sqlite3=yes], [have_supported_sqlite3=no])
], [have_sqlite3=no])
- AC_CHECK_LIB([sqlite3], [sqlite3_load_extension])
+ AC_CHECK_LIB([sqlite3], [sqlite3_load_extension],
+ [have_sqlite3_load_extension=yes],
+ [have_sqlite3_load_extension=no])
])
AS_VAR_COPY([CFLAGS], [save_CFLAGS])