summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2022-06-24 10:40:43 (GMT)
committerGitHub <noreply@github.com>2022-06-24 10:40:43 (GMT)
commit8625802d854ec0152177a6ff0ac092e0e3ff98a5 (patch)
treed401c4014ca633de8cbdbc9db7b57b2bbdb2bb21 /configure.ac
parentab077d1e17032f84514292ae3fb8dee9bcfd2ce9 (diff)
downloadcpython-8625802d854ec0152177a6ff0ac092e0e3ff98a5.zip
cpython-8625802d854ec0152177a6ff0ac092e0e3ff98a5.tar.gz
cpython-8625802d854ec0152177a6ff0ac092e0e3ff98a5.tar.bz2
gh-84461: Fix ctypes and test_ctypes on Emscripten (#94142)
- c_longlong and c_longdouble need experimental WASM bigint. - Skip tests that need threading - Define ``CTYPES_MAX_ARGCOUNT`` for Emscripten. libffi-emscripten 2022-06-23 supports up to 1000 args.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4f8e7e3..3b70532 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1486,10 +1486,10 @@ if test -z "$HOSTRUNNER"
then
AS_CASE([$ac_sys_system/$ac_sys_emscripten_target],
[Emscripten/node*], [
+ # bigint for ctypes c_longlong, c_longdouble
+ HOSTRUNNER="node --experimental-wasm-bigint"
AS_VAR_IF([enable_wasm_pthreads], [yes], [
- HOSTRUNNER='node --experimental-wasm-threads --experimental-wasm-bulk-memory'
- ], [
- HOSTRUNNER='node'
+ HOSTRUNNER="$HOSTRUNNER --experimental-wasm-threads --experimental-wasm-bulk-memory"
])
],
dnl TODO: support other WASI runtimes