summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2012-10-21 21:12:35 (GMT)
committerMatthias Klose <doko@ubuntu.com>2012-10-21 21:12:35 (GMT)
commitaee3c76acf068b5f7b3f709c42b8bbefbce0d84b (patch)
tree4397322f398893272d4e6df8a5142088e103e260 /configure.ac
parent18b7fcc7a627733ae8f9d72cb1f95f3d7d40696e (diff)
parentc4c4842d8625db87bfdd916a3751f90e8a0f9d88 (diff)
downloadcpython-aee3c76acf068b5f7b3f709c42b8bbefbce0d84b.zip
cpython-aee3c76acf068b5f7b3f709c42b8bbefbce0d84b.tar.gz
cpython-aee3c76acf068b5f7b3f709c42b8bbefbce0d84b.tar.bz2
- Issue #16262: fix out-of-src-tree builds, if mercurial is not installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 4eb6c43..236951c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1000,12 +1000,12 @@ if test "$cross_compiling" = yes; then
fi
AC_SUBST(READELF)
-AC_SUBST(DISABLE_ASDLGEN)
-DISABLE_ASDLGEN=""
-AC_CHECK_PROG(HAS_PYTHON, python, found, not-found)
-if test $HAS_HG != found -o $HAS_PYTHON != found
-then
- DISABLE_ASDLGEN="@echo hg: $HAS_HG, python: $HAS_PYTHON! cannot run \$(srcdir)/Parser/asdl_c.py #"
+AC_SUBST(ASDLGEN)
+AC_CHECK_PROGS(PYTHON, python$PACKAGE_VERSION python3 python, not-found)
+if $PYTHON = not-found; then
+ ASDLGEN="@echo python: $PYTHON! cannot run \$(srcdir)/Parser/asdl_c.py #"
+else
+ ASDLGEN="$PYTHON"
fi