summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles-François Natali <neologix@free.fr>2013-01-08 18:47:00 (GMT)
committerCharles-François Natali <neologix@free.fr>2013-01-08 18:47:00 (GMT)
commitbe2b907ce2252785e257a9642f36e95e297ae449 (patch)
treead985016ee7d40e6501d3f8acf3e015885316b02 /configure.ac
parent3a5fc4bcb83546141b37f02ec49ee6470452c08e (diff)
downloadcpython-be2b907ce2252785e257a9642f36e95e297ae449.zip
cpython-be2b907ce2252785e257a9642f36e95e297ae449.tar.gz
cpython-be2b907ce2252785e257a9642f36e95e297ae449.tar.bz2
Issue #16836: Enable IPv6 support even if IPv6 is disabled on the build host.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 3 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index d7399eb..db6b0b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2517,25 +2517,15 @@ AC_ARG_ENABLE(ipv6,
[
dnl the check does not work on cross compilation case...
- AC_RUN_IFELSE([AC_LANG_SOURCE([[ /* AF_INET6 available check */
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ /* AF_INET6 available check */
#include <sys/types.h>
-#include <sys/socket.h>
-main()
-{
- if (socket(AF_INET6, SOCK_STREAM, 0) < 0)
- exit(1);
- else
- exit(0);
-}
-]])],[
+#include <sys/socket.h>]],
+[[int domain = AF_INET6;]])],[
AC_MSG_RESULT(yes)
ipv6=yes
],[
AC_MSG_RESULT(no)
ipv6=no
-],[
- AC_MSG_RESULT(no)
- ipv6=no
])
if test "$ipv6" = "yes"; then