summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-11-28 12:28:25 (GMT)
committerVictor Stinner <victor.stinner@gmail.com>2014-11-28 12:28:25 (GMT)
commitbeeb512fe1d8c502d854d7e27742a7481bccd5c4 (patch)
tree8e89fe1a29f57d4ea5f0e095110f257d77680a00 /configure.ac
parent07ff92a0d2c98f55bd863cdc5d6f62975f4994e5 (diff)
downloadcpython-beeb512fe1d8c502d854d7e27742a7481bccd5c4.zip
cpython-beeb512fe1d8c502d854d7e27742a7481bccd5c4.tar.gz
cpython-beeb512fe1d8c502d854d7e27742a7481bccd5c4.tar.bz2
Issue #21356: Make ssl.RAND_egd() optional to support LibreSSL. The
availability of the function is checked during the compilation. Patch written by Bernard Spil.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c12622b..99d430c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2293,6 +2293,9 @@ AC_MSG_RESULT($SHLIBS)
AC_CHECK_LIB(sendfile, sendfile)
AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
+AC_CHECK_LIB(crypto, RAND_egd,
+ AC_DEFINE(HAVE_RAND_EGD, 1,
+ [Define if the libcrypto has RAND_egd]))
# only check for sem_init if thread support is requested
if test "$with_threads" = "yes" -o -z "$with_threads"; then