summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorErlend E. Aasland <erlend.aasland@protonmail.com>2023-06-07 07:41:17 (GMT)
committerGitHub <noreply@github.com>2023-06-07 07:41:17 (GMT)
commitc607551baf62d7201b147f20095160eee0140684 (patch)
tree510c21d34070aa88360cce1f2ab15f23a5dc70fa /configure.ac
parent2cfe778d7ff5872cce048d5745f8f23b6d45728c (diff)
downloadcpython-c607551baf62d7201b147f20095160eee0140684.zip
cpython-c607551baf62d7201b147f20095160eee0140684.tar.gz
cpython-c607551baf62d7201b147f20095160eee0140684.tar.bz2
[3.12] gh-89886: Use Autoconf quadrigraphs where appropriate (#105226) (#105423)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac88
1 files changed, 44 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac
index dc9359e..14354a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2616,7 +2616,7 @@ yes)
AC_MSG_RESULT([$MACOSX_DEPLOYMENT_TARGET])
AC_MSG_CHECKING([if specified universal architectures work])
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[printf("%d", 42);]])],
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[@%:@include <stdio.h>]], [[printf("%d", 42);]])],
[AC_MSG_RESULT([yes])],
[AC_MSG_RESULT([no])
AC_MSG_ERROR([check config.log and use the '--with-universal-archs' option])
@@ -3057,7 +3057,7 @@ fi
AC_CACHE_CHECK([for pthread_t], [ac_cv_have_pthread_t], [
AC_COMPILE_IFELSE([
- AC_LANG_PROGRAM([[#include <pthread.h>]], [[pthread_t x; x = *(pthread_t*)0;]])
+ AC_LANG_PROGRAM([[@%:@include <pthread.h>]], [[pthread_t x; x = *(pthread_t*)0;]])
], [ac_cv_have_pthread_t=yes], [ac_cv_have_pthread_t=no])
])
AS_VAR_IF([ac_cv_have_pthread_t], [yes], [
@@ -3070,11 +3070,11 @@ AS_VAR_IF([ac_cv_have_pthread_t], [yes], [
# Issue #25658: POSIX hasn't defined that pthread_key_t is compatible with int.
# This checking will be unnecessary after removing deprecated TLS API.
-AC_CHECK_SIZEOF([pthread_key_t], [], [[#include <pthread.h>]])
+AC_CHECK_SIZEOF([pthread_key_t], [], [[@%:@include <pthread.h>]])
AC_CACHE_CHECK([whether pthread_key_t is compatible with int], [ac_cv_pthread_key_t_is_arithmetic_type], [
if test "$ac_cv_sizeof_pthread_key_t" -eq "$ac_cv_sizeof_int" ; then
AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM([[#include <pthread.h>]], [[pthread_key_t k; k * 1;]])],
+ [AC_LANG_PROGRAM([[@%:@include <pthread.h>]], [[pthread_key_t k; k * 1;]])],
[ac_cv_pthread_key_t_is_arithmetic_type=yes],
[ac_cv_pthread_key_t_is_arithmetic_type=no]
)
@@ -3615,7 +3615,7 @@ AC_CHECK_LIB([intl], [textdomain],
case "$ac_sys_system" in
AIX*) AC_MSG_CHECKING([for genuine AIX C++ extensions support])
AC_LINK_IFELSE([
- AC_LANG_PROGRAM([[#include <load.h>]],
+ AC_LANG_PROGRAM([[@%:@include <load.h>]],
[[loadAndInit("", 0, "")]])
],[
AC_DEFINE([AIX_GENUINE_CPLUSPLUS], [1],
@@ -3833,9 +3833,9 @@ AS_VAR_IF([have_libffi], [yes], [
CFLAGS="$LIBFFI_CFLAGS $CFLAGS"
LDFLAGS="$LIBFFI_LIBS $LDFLAGS"
- PY_CHECK_FUNC([ffi_prep_cif_var], [#include <ffi.h>])
- PY_CHECK_FUNC([ffi_prep_closure_loc], [#include <ffi.h>])
- PY_CHECK_FUNC([ffi_closure_alloc], [#include <ffi.h>])
+ PY_CHECK_FUNC([ffi_prep_cif_var], [@%:@include <ffi.h>])
+ PY_CHECK_FUNC([ffi_prep_closure_loc], [@%:@include <ffi.h>])
+ PY_CHECK_FUNC([ffi_closure_alloc], [@%:@include <ffi.h>])
])
])
@@ -4473,7 +4473,7 @@ AC_ARG_ENABLE([ipv6],
dnl the check does not work on cross compilation case...
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ /* AF_INET6 available check */
#include <sys/types.h>
-#include <sys/socket.h>]],
+@%:@include <sys/socket.h>]],
[[int domain = AF_INET6;]])],[
ipv6=yes
],[
@@ -4490,7 +4490,7 @@ if test "$ipv6" = "yes"; then
AC_MSG_CHECKING([if RFC2553 API is available])
AC_COMPILE_IFELSE([
AC_LANG_PROGRAM([[#include <sys/types.h>
-#include <netinet/in.h>]],
+@%:@include <netinet/in.h>]],
[[struct sockaddr_in6 x;
x.sin6_scope_id;]])
],[
@@ -4522,7 +4522,7 @@ if test "$ipv6" = "yes"; then
#include <netinet/in.h>
#ifdef IPV6_INRIA_VERSION
yes
-#endif],
+@%:@endif],
[ipv6type=$i])
;;
kame)
@@ -4531,7 +4531,7 @@ yes
#include <netinet/in.h>
#ifdef __KAME__
yes
-#endif],
+@%:@endif],
[ipv6type=$i;
ipv6lib=inet6
ipv6libdir=/usr/local/v6/lib
@@ -4543,7 +4543,7 @@ yes
#include <features.h>
#if defined(__GLIBC__) && ((__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1) || (__GLIBC__ > 2))
yes
-#endif],
+@%:@endif],
[ipv6type=$i;
ipv6trylibc=yes])
;;
@@ -4569,7 +4569,7 @@ yes
#include <sys/param.h>
#ifdef _TOSHIBA_INET6
yes
-#endif],
+@%:@endif],
[ipv6type=$i;
ipv6lib=inet6;
ipv6libdir=/usr/local/v6/lib])
@@ -4579,7 +4579,7 @@ yes
#include </usr/local/v6/include/sys/v6config.h>
#ifdef __V6D__
yes
-#endif],
+@%:@endif],
[ipv6type=$i;
ipv6lib=v6;
ipv6libdir=/usr/local/v6/lib;
@@ -4590,7 +4590,7 @@ yes
#include <sys/param.h>
#ifdef _ZETA_MINAMI_INET6
yes
-#endif],
+@%:@endif],
[ipv6type=$i;
ipv6lib=inet6;
ipv6libdir=/usr/local/v6/lib])
@@ -4623,7 +4623,7 @@ fi
AC_CACHE_CHECK([CAN_RAW_FD_FRAMES], [ac_cv_can_raw_fd_frames], [
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ /* CAN_RAW_FD_FRAMES available check */
-#include <linux/can/raw.h>]],
+@%:@include <linux/can/raw.h>]],
[[int can_raw_fd_frames = CAN_RAW_FD_FRAMES;]])],
[ac_cv_can_raw_fd_frames=yes],
[ac_cv_can_raw_fd_frames=no])
@@ -4635,7 +4635,7 @@ AS_VAR_IF([ac_cv_can_raw_fd_frames], [yes], [
AC_CACHE_CHECK([for CAN_RAW_JOIN_FILTERS], [ac_cv_can_raw_join_filters], [
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include <linux/can/raw.h>]],
+@%:@include <linux/can/raw.h>]],
[[int can_raw_join_filters = CAN_RAW_JOIN_FILTERS;]])],
[ac_cv_can_raw_join_filters=yes],
[ac_cv_can_raw_join_filters=no])
@@ -4882,14 +4882,14 @@ AC_CHECK_DECL([dirfd],
# For some functions, having a definition is not sufficient, since
# we want to take their address.
-PY_CHECK_FUNC([chroot], [#include <unistd.h>])
-PY_CHECK_FUNC([link], [#include <unistd.h>])
-PY_CHECK_FUNC([symlink], [#include <unistd.h>])
-PY_CHECK_FUNC([fchdir], [#include <unistd.h>])
-PY_CHECK_FUNC([fsync], [#include <unistd.h>])
-PY_CHECK_FUNC([fdatasync], [#include <unistd.h>])
-PY_CHECK_FUNC([epoll_create], [#include <sys/epoll.h>], [HAVE_EPOLL])
-PY_CHECK_FUNC([epoll_create1], [#include <sys/epoll.h>])
+PY_CHECK_FUNC([chroot], [@%:@include <unistd.h>])
+PY_CHECK_FUNC([link], [@%:@include <unistd.h>])
+PY_CHECK_FUNC([symlink], [@%:@include <unistd.h>])
+PY_CHECK_FUNC([fchdir], [@%:@include <unistd.h>])
+PY_CHECK_FUNC([fsync], [@%:@include <unistd.h>])
+PY_CHECK_FUNC([fdatasync], [@%:@include <unistd.h>])
+PY_CHECK_FUNC([epoll_create], [@%:@include <sys/epoll.h>], [HAVE_EPOLL])
+PY_CHECK_FUNC([epoll_create1], [@%:@include <sys/epoll.h>])
PY_CHECK_FUNC([kqueue],[
#include <sys/types.h>
#include <sys/event.h>
@@ -4899,7 +4899,7 @@ PY_CHECK_FUNC([prlimit], [
#include <sys/resource.h>
])
-PY_CHECK_FUNC([_dyld_shared_cache_contains_path], [#include <mach-o/dyld.h>], [HAVE_DYLD_SHARED_CACHE_CONTAINS_PATH])
+PY_CHECK_FUNC([_dyld_shared_cache_contains_path], [@%:@include <mach-o/dyld.h>], [HAVE_DYLD_SHARED_CACHE_CONTAINS_PATH])
PY_CHECK_FUNC([memfd_create], [
#ifdef HAVE_SYS_MMAN_H
@@ -4922,12 +4922,12 @@ PY_CHECK_FUNC([eventfd], [
# address to avoid compiler warnings and potential miscompilations
# because of the missing prototypes.
-PY_CHECK_FUNC([ctermid_r], [#include <stdio.h>])
+PY_CHECK_FUNC([ctermid_r], [@%:@include <stdio.h>])
AC_CACHE_CHECK([for flock declaration], [ac_cv_flock_decl],
[AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
- [#include <sys/file.h>],
+ [@%:@include <sys/file.h>],
[void* p = flock]
)],
[ac_cv_flock_decl=yes],
@@ -4939,12 +4939,12 @@ AS_VAR_IF([ac_cv_flock_decl], [yes],
[AC_CHECK_FUNCS([flock], [],
[AC_CHECK_LIB([bsd], [flock], [FCNTL_LIBS="-lbsd"])])])
-PY_CHECK_FUNC([getpagesize], [#include <unistd.h>])
+PY_CHECK_FUNC([getpagesize], [@%:@include <unistd.h>])
AC_CACHE_CHECK([for broken unsetenv], [ac_cv_broken_unsetenv],
[AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
- [#include <stdlib.h>],
+ [@%:@include <stdlib.h>],
[int res = unsetenv("DUMMY")])],
[ac_cv_broken_unsetenv=no],
[ac_cv_broken_unsetenv=yes]
@@ -5072,7 +5072,7 @@ PKG_CHECK_MODULES([LIBLZMA], [liblzma], [have_liblzma=yes], [
])
dnl PY_CHECK_NETDB_FUNC(FUNCTION)
-AC_DEFUN([PY_CHECK_NETDB_FUNC], [PY_CHECK_FUNC([$1], [#include <netdb.h>])])
+AC_DEFUN([PY_CHECK_NETDB_FUNC], [PY_CHECK_FUNC([$1], [@%:@include <netdb.h>])])
PY_CHECK_NETDB_FUNC([hstrerror])
dnl not available in WASI yet
@@ -5395,10 +5395,10 @@ AC_CHECK_MEMBERS([struct passwd.pw_gecos, struct passwd.pw_passwd], [], [], [[
#include <pwd.h>
]])
# Issue #21085: In Cygwin, siginfo_t does not have si_band field.
-AC_CHECK_MEMBERS([siginfo_t.si_band], [], [], [[#include <signal.h>]])
+AC_CHECK_MEMBERS([siginfo_t.si_band], [], [], [[@%:@include <signal.h>]])
AC_CACHE_CHECK([for time.h that defines altzone], [ac_cv_header_time_altzone], [
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <time.h>]], [[return altzone;]])],
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[@%:@include <time.h>]], [[return altzone;]])],
[ac_cv_header_time_altzone=yes],
[ac_cv_header_time_altzone=no])
])
@@ -5408,7 +5408,7 @@ if test $ac_cv_header_time_altzone = yes; then
fi
AC_CACHE_CHECK([for addrinfo], [ac_cv_struct_addrinfo],
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <netdb.h>]], [[struct addrinfo a]])],
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[@%:@include <netdb.h>]], [[struct addrinfo a]])],
[ac_cv_struct_addrinfo=yes],
[ac_cv_struct_addrinfo=no]))
if test $ac_cv_struct_addrinfo = yes; then
@@ -5418,7 +5418,7 @@ fi
AC_CACHE_CHECK([for sockaddr_storage], [ac_cv_struct_sockaddr_storage],
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
# include <sys/types.h>
-# include <sys/socket.h>]], [[struct sockaddr_storage s]])],
+@%:@ include <sys/socket.h>]], [[struct sockaddr_storage s]])],
[ac_cv_struct_sockaddr_storage=yes],
[ac_cv_struct_sockaddr_storage=no]))
if test $ac_cv_struct_sockaddr_storage = yes; then
@@ -5430,7 +5430,7 @@ AC_CACHE_CHECK([for sockaddr_alg], [ac_cv_struct_sockaddr_alg],
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
# include <sys/types.h>
# include <sys/socket.h>
-# include <linux/if_alg.h>]], [[struct sockaddr_alg s]])],
+@%:@ include <linux/if_alg.h>]], [[struct sockaddr_alg s]])],
[ac_cv_struct_sockaddr_alg=yes],
[ac_cv_struct_sockaddr_alg=no]))
if test $ac_cv_struct_sockaddr_alg = yes; then
@@ -5469,7 +5469,7 @@ PY_CHECK_FUNC([socketpair], [
# check if sockaddr has sa_len member
AC_CACHE_CHECK([if sockaddr has sa_len member], [ac_cv_struct_sockaddr_sa_len], [
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
-#include <sys/socket.h>]], [[struct sockaddr x;
+@%:@include <sys/socket.h>]], [[struct sockaddr x;
x.sa_len = 0;]])],
[ac_cv_struct_sockaddr_sa_len=yes], [ac_cv_struct_sockaddr_sa_len=no])
])
@@ -5803,7 +5803,7 @@ AS_VAR_IF([ac_cv_broken_sem_getvalue], [yes], [
)
])
-AC_CHECK_DECLS([RTLD_LAZY, RTLD_NOW, RTLD_GLOBAL, RTLD_LOCAL, RTLD_NODELETE, RTLD_NOLOAD, RTLD_DEEPBIND, RTLD_MEMBER], [], [], [[#include <dlfcn.h>]])
+AC_CHECK_DECLS([RTLD_LAZY, RTLD_NOW, RTLD_GLOBAL, RTLD_LOCAL, RTLD_NODELETE, RTLD_NOLOAD, RTLD_DEEPBIND, RTLD_MEMBER], [], [], [[@%:@include <dlfcn.h>]])
# determine what size digit to use for Python's longs
AC_MSG_CHECKING([digit size for Python's longs])
@@ -6020,7 +6020,7 @@ fi
# check for getc_unlocked and related locking functions
AC_CACHE_CHECK([for getc_unlocked() and friends], [ac_cv_have_getc_unlocked], [
-AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[
+AC_LINK_IFELSE([AC_LANG_PROGRAM([[@%:@include <stdio.h>]], [[
FILE *f = fopen("/dev/null", "r");
flockfile(f);
getc_unlocked(f);
@@ -6326,7 +6326,7 @@ fi
# Look for subsecond timestamps in struct stat
AC_CACHE_CHECK([for tv_nsec in struct stat], [ac_cv_stat_tv_nsec],
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/stat.h>]], [[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[@%:@include <sys/stat.h>]], [[
struct stat st;
st.st_mtim.tv_nsec = 1;
]])],
@@ -6340,7 +6340,7 @@ fi
# Look for BSD style subsecond timestamps in struct stat
AC_CACHE_CHECK([for tv_nsec2 in struct stat], [ac_cv_stat_tv_nsec2],
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/stat.h>]], [[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[@%:@include <sys/stat.h>]], [[
struct stat st;
st.st_mtimespec.tv_nsec = 1;
]])],
@@ -6483,7 +6483,7 @@ AC_CHECK_HEADERS([term.h], [], [], [
# On HP/UX 11.0, mvwdelch is a block with a return statement
AC_CACHE_CHECK([whether mvwdelch is an expression], [ac_cv_mvwdelch_is_expression],
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <curses.h>]], [[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[@%:@include <curses.h>]], [[
int rtn;
rtn = mvwdelch(0,0,0);
]])],
@@ -6527,7 +6527,7 @@ AC_DEFUN([PY_CHECK_CURSES_FUNC],
[py_var],
[AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
- [#include <curses.h>], [
+ [@%:@include <curses.h>], [
#ifndef $1
void *x=$1
#endif