summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Snow <ericsnowcurrently@gmail.com>2022-05-27 23:38:01 (GMT)
committerGitHub <noreply@github.com>2022-05-27 23:38:01 (GMT)
commitcaa279d6fd5f151e57f891cd4f6ba51b532501c6 (patch)
treec19c87efdefab0b4e4a5291896cfb86e37ec90f2 /configure.ac
parente6a57678cafe18ca132ee9510252168fcc392a8d (diff)
downloadcpython-caa279d6fd5f151e57f891cd4f6ba51b532501c6.zip
cpython-caa279d6fd5f151e57f891cd4f6ba51b532501c6.tar.gz
cpython-caa279d6fd5f151e57f891cd4f6ba51b532501c6.tar.bz2
bpo-40514: Drop EXPERIMENTAL_ISOLATED_SUBINTERPRETERS (gh-93185)
This was added for bpo-40514 (gh-84694) to test out a per-interpreter GIL. However, it has since proven unnecessary to keep the experiment in the repo. (It can be done as a branch in a fork like normal.) So here we are removing: * the configure option * the macro * the code enabled by the macro
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 9b5926d..e925bc0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6540,23 +6540,6 @@ AS_VAR_IF([with_builtin_blake2], [yes], [
], [have_libb2=no])
])
-# --with-experimental-isolated-subinterpreters
-AH_TEMPLATE(EXPERIMENTAL_ISOLATED_SUBINTERPRETERS,
- [Better isolate subinterpreters, experimental build mode.])
-AC_MSG_CHECKING(for --with-experimental-isolated-subinterpreters)
-AC_ARG_WITH(experimental-isolated-subinterpreters,
- AS_HELP_STRING([--with-experimental-isolated-subinterpreters],
- [better isolate subinterpreters, experimental build mode (default is no)]),
-[
-if test "$withval" != no
-then
- AC_MSG_RESULT(yes);
- AC_DEFINE(EXPERIMENTAL_ISOLATED_SUBINTERPRETERS)
-else
- AC_MSG_RESULT(no);
-fi],
-[AC_MSG_RESULT(no)])
-
# Check whether to disable test modules. Once set, setup.py will not build
# test extension modules and "make install" will not install test suites.
AC_MSG_CHECKING([for --disable-test-modules])