summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2022-01-05 09:54:17 (GMT)
committerGitHub <noreply@github.com>2022-01-05 09:54:17 (GMT)
commitcae55542d23e606dde9819d5dadd7430085fcc77 (patch)
tree6aa212394695842e7b8d283a238ff4d48aa8aa5c /configure.ac
parent91bc6f9615eabb10090e2e4f0fe5913885a29c8c (diff)
downloadcpython-cae55542d23e606dde9819d5dadd7430085fcc77.zip
cpython-cae55542d23e606dde9819d5dadd7430085fcc77.tar.gz
cpython-cae55542d23e606dde9819d5dadd7430085fcc77.tar.bz2
bpo-46263: Don't use MULTIARCH on FreeBSD (#30410)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 050b907..d9bdf9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -987,10 +987,14 @@ else
fi
rm -f conftest.c conftest.out
-if test x$PLATFORM_TRIPLET != xdarwin; then
- MULTIARCH=$($CC --print-multiarch 2>/dev/null)
-fi
-AC_SUBST(MULTIARCH)
+AC_MSG_CHECKING([for multiarch])
+AS_CASE([$ac_sys_system],
+ [Darwin*], [MULTIARCH=""],
+ [FreeBSD*], [MULTIARCH=""],
+ [MULTIARCH=$($CC --print-multiarch 2>/dev/null)]
+)
+AC_SUBST([MULTIARCH])
+AC_MSG_RESULT([$MULTIARCH])
if test x$PLATFORM_TRIPLET != x && test x$MULTIARCH != x; then
if test x$PLATFORM_TRIPLET != x$MULTIARCH; then
@@ -1000,6 +1004,7 @@ elif test x$PLATFORM_TRIPLET != x && test x$MULTIARCH = x; then
MULTIARCH=$PLATFORM_TRIPLET
fi
AC_SUBST(PLATFORM_TRIPLET)
+
if test x$MULTIARCH != x; then
MULTIARCH_CPPFLAGS="-DMULTIARCH=\\\"$MULTIARCH\\\""
fi