summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2022-07-01 07:23:41 (GMT)
committerGitHub <noreply@github.com>2022-07-01 07:23:41 (GMT)
commitd6acdc1b60de4f6fd05c6654a9661b7edddf0448 (patch)
tree792904372e57492b29d62813f768884af99a0032 /configure.ac
parent62bb7a3b50150495e215d7bd32f633eef81b3bc2 (diff)
downloadcpython-d6acdc1b60de4f6fd05c6654a9661b7edddf0448.zip
cpython-d6acdc1b60de4f6fd05c6654a9661b7edddf0448.tar.gz
cpython-d6acdc1b60de4f6fd05c6654a9661b7edddf0448.tar.bz2
gh-90005-ffi: Fix building _ctypes without pkg-config (GH-94451)
The fallback path did not set LIBFFI_LIBS variable to link with ``-lffi``.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ab1c687..12ae2ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3605,7 +3605,10 @@ AS_VAR_IF([with_system_ffi], [yes], [
PKG_CHECK_MODULES([LIBFFI], [libffi], [have_libffi=yes], [
AC_CHECK_HEADER([ffi.h], [
WITH_SAVE_ENV([
- AC_CHECK_LIB([ffi], [ffi_call], [have_libffi=yes], [have_libffi=no])
+ AC_CHECK_LIB([ffi], [ffi_call], [
+ have_libffi=yes
+ LIBFFI_LIBS="-lffi"
+ ], [have_libffi=no])
])
])
])