summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2021-11-23 20:36:40 (GMT)
committerGitHub <noreply@github.com>2021-11-23 20:36:40 (GMT)
commitf840398a5fd8741653c26eb8641c48656c9800d4 (patch)
tree60e0df1663a23a1f4519eaa2d05d46d74ec74cc8 /configure.ac
parent4ae26b9c1d0c33e3db92c6f305293f9240dea358 (diff)
downloadcpython-f840398a5fd8741653c26eb8641c48656c9800d4.zip
cpython-f840398a5fd8741653c26eb8641c48656c9800d4.tar.gz
cpython-f840398a5fd8741653c26eb8641c48656c9800d4.tar.bz2
bpo-45873: Restore Python 3.6 compatibility (GH-29730)
Co-authored-by: Guido van Rossum <gvanrossum@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ba22418..e539d3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,9 +96,18 @@ AC_SUBST(host)
# pybuilddir.txt will be created by --generate-posix-vars in the Makefile
rm -f pybuilddir.txt
-AC_CHECK_PROGS(PYTHON_FOR_REGEN, python$PACKAGE_VERSION python3 python, python3)
+AC_CHECK_PROGS([PYTHON_FOR_REGEN],
+ [python$PACKAGE_VERSION python3.10 python3.9 python3.8 python3.7 python3.6 python3 python],
+ [python3])
AC_SUBST(PYTHON_FOR_REGEN)
+AC_MSG_CHECKING([Python for regen version])
+if command -v $PYTHON_FOR_REGEN >/dev/null 2>&1; then
+ AC_MSG_RESULT([$($PYTHON_FOR_REGEN -V 2>/dev/null)])
+else
+ AC_MSG_RESULT([missing])
+fi
+
if test "$cross_compiling" = yes; then
AC_MSG_CHECKING([for python interpreter for cross build])
if test -z "$PYTHON_FOR_BUILD"; then