summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Protzenko <protz@microsoft.com>2023-02-22 21:18:43 (GMT)
committerGitHub <noreply@github.com>2023-02-22 21:18:43 (GMT)
commitfcadc7e405141847ab10daf5cff16be880083a24 (patch)
tree404c9bc7b90e95882765731171033632aa6c9b80 /configure.ac
parent96bf24380e44dfa1516d65480250995e737c0cb9 (diff)
downloadcpython-fcadc7e405141847ab10daf5cff16be880083a24.zip
cpython-fcadc7e405141847ab10daf5cff16be880083a24.tar.gz
cpython-fcadc7e405141847ab10daf5cff16be880083a24.tar.bz2
gh-99108: Import MD5 and SHA1 from HACL* (#102089)
Replaces our fallback non-OpenSSL MD5 and SHA1 implementations with those from HACL* as we've already done with SHA2.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bc288b8..982f669 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7194,8 +7194,12 @@ PY_STDLIB_MOD_SIMPLE([unicodedata])
dnl By default we always compile these even when OpenSSL is available
dnl (issue #14693). The modules are small.
-PY_STDLIB_MOD([_md5], [test "$with_builtin_md5" = yes])
-PY_STDLIB_MOD([_sha1], [test "$with_builtin_sha1" = yes])
+PY_STDLIB_MOD([_md5],
+ [test "$with_builtin_md5" = yes], [],
+ [-I\$(srcdir)/Modules/_hacl/include -I\$(srcdir)/Modules/_hacl/internal -D_BSD_SOURCE -D_DEFAULT_SOURCE])
+PY_STDLIB_MOD([_sha1],
+ [test "$with_builtin_sha1" = yes], [],
+ [-I\$(srcdir)/Modules/_hacl/include -I\$(srcdir)/Modules/_hacl/internal -D_BSD_SOURCE -D_DEFAULT_SOURCE])
PY_STDLIB_MOD([_sha2],
[test "$with_builtin_sha2" = yes], [],
[-I\$(srcdir)/Modules/_hacl/include -I\$(srcdir)/Modules/_hacl/internal -D_BSD_SOURCE -D_DEFAULT_SOURCE])